Bug 1410109 - Alerting issue in Metrics 0.21
Summary: Alerting issue in Metrics 0.21
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Hawkular
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Matt Wringe
QA Contact: Peng Li
URL:
Whiteboard:
Depends On:
Blocks: 1415833
TreeView+ depends on / blocked
 
Reported: 2017-01-04 13:30 UTC by Jay Shaughnessy
Modified: 2018-07-26 19:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1415833 (view as bug list)
Environment:
Last Closed: 2017-05-30 12:48:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker HWKALERTS-210 0 Blocker Resolved Autoresolve does not work on clustering setup 2017-03-26 03:19:00 UTC

Description Jay Shaughnessy 2017-01-04 13:30:47 UTC
Description of problem:
Metrics version 0.21 suffers from the alerting issue described by https://issues.jboss.org/browse/HWKALERTS-210.  OS should move to Hawkular Metrics 0.23 or higher to resolve the issue.

Comment 7 Jay Shaughnessy 2017-01-20 13:10:38 UTC
The fix for hwkalerts-210 has been backported to the 1.3.x line and is now released in Alerting 1.3.3.Final. A PR has been generated to have Alerting 1.3.3.Final in Metrics 0.21.6, which is targeted for the OS 3.4.x line.

So, to be clear, the alerting issue should be fixed when updating to Metrics 0.21.6 (or higher).

Comment 8 Matt Wringe 2017-01-26 15:36:54 UTC
This should now be fixed in the Origin Metrics.

Comment 9 Peng Li 2017-02-04 08:47:56 UTC
verified with hawkular metrics 3.4.1
metrics-hawkular-metrics   3.4.1               ea4c68d376ca        18 hours ago        1.5 GB

hawkular version is 0.21.6.Final-redhat-1
(Git SHA1 - 55b78140efed77aaa793579aac3e0ed7f15b72ad)

Comment 10 Matt Wringe 2017-02-06 14:46:30 UTC
@jshaughn do you have a test case we can use to test this?

Comment 11 Jay Shaughnessy 2017-02-06 16:28:58 UTC
@mwringe, we did not automate the recreate-steps on this BZ, the scripts were used to reproduce and validate.  We have since continued to enhance our overall cluster-profile integration tests, see  https://issues.jboss.org/browse/HWKALERTS-218 for recent enhancements.  These is no specific automation for this bug, we are backporting only the fix.


Note You need to log in before you can comment on or make changes to this bug.