Bug 141012 - AVI Files playing crooked and broken in Totem
AVI Files playing crooked and broken in Totem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
http://jimmac.musichall.cz/demos/gimp...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-27 23:15 EST by Steven Garrity
Modified: 2013-03-13 00:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.3.92
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-14 16:13:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of crooked nautilus thumbnail (14.86 KB, image/png)
2006-03-08 08:33 EST, Steven Garrity
no flags Details

  None (edit)
Description Steven Garrity 2004-11-27 23:15:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Playing some (not sure if it's all) AVI video files in Totem with
Gstreamer, the videos will play, but heavily distored - with the
picture skewed at a 45-degree angle.

I tried to take a screenshot of the video from within Totem, but
Totem's Edit - Take Screenshot feature didn't seem to do anything.

There's a link to one of the videos that was playing this way:
http://jimmac.musichall.cz/demos/gimp/toolbox.avi

The same videos display normally/properly in mplayer.

Version-Release number of selected component (if applicable):
gstreamer-plugins-0.8.5-1
gstreamer-0.8.7-3
totem-0.99.19-1

How reproducible: Always

Steps to Reproduce:
1. Open video (http://jimmac.musichall.cz/demos/gimp/toolbox.avi) in Totem
2. Play
3. Watch in horror
Comment 1 Michael Jakob 2005-02-08 15:26:05 EST
I can confirm this problem; it seems to be caused by the esdsink
plugin. All pipelines that end in esdsink have distorted output; this
doesn't depend on the stream source.  As a workaround, configure
gstreamer to use osssink (or alsasink, but that one tends to crash
with some streams - see also #142823.)
(gstreamer-plugins-0.8.5-1, gstreamer-0.8.7-4.FC3.0)
Comment 2 Michael Jakob 2005-02-09 13:03:12 EST
I investigated a little further, and I think the problem is not caused
by gstreamer/gstreamer-plugins (at least in my case.)  I installed the
same packages (including gstreamer-*, alsa-*, kernel-*) on my
notebook, and everything works ok there.  Seems to be a problem of the
sound driver, or maybe even the hardware; on-board soundcards suck. 
Sorry about the noise :-)
Comment 3 John Thacker 2006-03-08 00:12:37 EST
1. I'm pretty sure that this video requires codecs which don't ship by default,
like gstreamer-ffmpeg or the new gstreamer-plugins-ugly.
2. With those plugins, this now plays fine for me.  Please retest and
(hopefully) close the bug.
Comment 4 Steven Garrity 2006-03-08 08:33:55 EST
Created attachment 125796 [details]
screenshot of crooked nautilus thumbnail

(In reply to comment #3)
> 2. With those plugins, this now plays fine for me.  Please retest and
> (hopefully) close the bug.

Still on FC4, but with ffmpeg available, this video does work now. However, the
Nautilus thumbnail still shows the distorted/crooked version (screenshot
attached)
Comment 5 John (J5) Palmieri 2006-03-08 11:18:22 EST
Most likely just cached in your .thumbnails directory.  You can delete the files
in there if you want to fix the issue.
Comment 6 Steven Garrity 2006-03-08 12:02:58 EST
(In reply to comment #5)
> Most likely just cached in your .thumbnails directory.  You can delete the files
> in there if you want to fix the issue.

I assumed this was the case too. However, even after clearing out everthing in
my .thumbnails dir, Nautilus regenerates the skewed-looking thumbnail.
Comment 7 Steven Garrity 2006-03-26 16:38:47 EST
Upgraded to FC5 and the upstream gstreamer-ffmpeg package for 0.10 and the
thumbnail is fixed now too. All seems well.
Comment 8 John Thacker 2006-04-14 16:13:08 EDT
In that case, let's close this bug, if it all works now.

Note You need to log in before you can comment on or make changes to this bug.