Bug 1410152 - devtoolset-3 missing dependencies
Summary: devtoolset-3 missing dependencies
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: softwarecollections.org
Classification: Community
Component: devtoolset-3
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Polacek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-04 15:30 UTC by Devin Bougie
Modified: 2017-06-30 07:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-30 07:50:49 UTC


Attachments (Terms of Use)

Description Devin Bougie 2017-01-04 15:30:13 UTC
devtoolset-3-eclipse-emf-runtime seems to be missing from http://mirror.centos.org/centos/6/sclo/x86_64/rh/devtoolset-3/

With the softwarecollections repo setup as:
------
[softwarecollections]
name=EL6 - SCLo rh
baseurl=http://mirror.centos.org/centos/6/sclo/$basearch/rh/
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo
------

"yum install devtoolset-3" fails with:
------
--> Finished Dependency Resolution
Error: Package: devtoolset-3-ide-3.1-12.el6.x86_64 (softwarecollections)
           Requires: devtoolset-3-eclipse-emf-sdk
Error: Package: devtoolset-3-ide-3.1-12.el6.x86_64 (softwarecollections)
           Requires: devtoolset-3-eclipse-emf-examples
Error: Package: devtoolset-3-eclipse-mylyn-builds-3.14.2-1.bootstrap1.el6.noarch (softwarecollections)
           Requires: devtoolset-3-eclipse-emf
Error: Package: devtoolset-3-ide-3.1-12.el6.x86_64 (softwarecollections)
           Requires: devtoolset-3-eclipse-emf-core
Error: Package: devtoolset-3-ide-3.1-12.el6.x86_64 (softwarecollections)
           Requires: devtoolset-3-eclipse-emf
Error: Package: 1:devtoolset-3-eclipse-platform-4.4.2-4.bootstrap2.el6.x86_64 (softwarecollections)
           Requires: devtoolset-3-eclipse-emf-core >= 1:2.10.2-2
Error: Package: 1:devtoolset-3-eclipse-platform-4.4.2-4.bootstrap2.el6.x86_64 (softwarecollections)
           Requires: devtoolset-3-eclipse-ecf-core >= 3.9.1-2.5
Error: Package: devtoolset-3-perftools-3.1-12.el6.x86_64 (softwarecollections)
           Requires: devtoolset-3-dyninst
 You could try using --skip-broken to work around the problem
------

For what it's worth devtoolset-3-eclipse-emf-runtime used to exist in the centos 6 sclo repo, and it does exist in the centos 7 sclo repo (http://mirror.centos.org/centos/7/sclo/x86_64/rh/devtoolset-3/).

Comment 1 Honza Horak 2017-01-09 09:39:18 UTC
Yes, this is unfortunately a known issue. We did not succeeded with rebuilding all eclipse packages for devtoolset-3 and there is currently no man-power to do it (there is quite a lot of bootstrapping needed).

However, I see currently these possibilities:
* somebody (you?) might help us rebuild the packages in cbs.centos.org
* you can use devtoolset-4 instead
* the older devtoolset-3 packages are still existing in copr: https://copr.fedorainfracloud.org/coprs/rhscl/devtoolset-3/

Comment 2 Honza Horak 2017-06-30 07:50:49 UTC
Since we already have newer devtoolset packages in SCLo SIG, I don't think we'll ever have enough capacity to build those old collections. So to not give any unrealistic hope, let's close this issue as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.