Bug 1410222 - Proxy installer should prompt to enable monitoring only for Sat 5.7 and lower (and not hosted)
Summary: Proxy installer should prompt to enable monitoring only for Sat 5.7 and lower...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomáš Kašpárek
QA Contact: Pavel Studeník
URL:
Whiteboard:
Depends On:
Blocks: 1340444
TreeView+ depends on / blocked
 
Reported: 2017-01-04 19:52 UTC by Eric Herget
Modified: 2017-06-21 12:07 UTC (History)
3 users (show)

Fixed In Version: spacewalk-proxy-installer-2.5.0-5-sat
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-21 12:07:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Eric Herget 2017-01-06 19:37:43 UTC
fixed in spacewalk.github:
d3900978889786fef86b4c840394653fb55c33da

Comment 2 Eric Herget 2017-01-06 19:38:51 UTC
This bug only addresses not prompting for, or attempting, monitoring install when satellite version is 5.8.  A subsequent fix will also prevent monitoring install when satellite proxy version is 5.8.

Comment 3 Pavel Studeník 2017-05-29 15:02:57 UTC
I thought that the issue is about situation when satellite has disable monitoring and prompt is not shown during installation.

1) disable monitoring on Satellite 5.6 or 5.7
2) run configure-proxy.sh
...
You do not have monitoring installed.
Do you want to install monitoring scout?
Will run 'yum install spacewalk-proxy-monitoring'. [Y/n]:

I suppose that correct behavior is that installation skip question about installation monitoring when the monitoring is not enabled on satellite.

Comment 4 Pavel Studeník 2017-06-06 11:01:13 UTC
I created new bug for previous issue - bug 1459121.

Comment 5 Pavel Studeník 2017-06-06 11:01:57 UTC
Verified with spacewalk-proxy-installer-2.5.0-10.el6sat.noarch


Note You need to log in before you can comment on or make changes to this bug.