Bug 1410234 - yum update --downloadonly doesn't resume download, and leaves temp files behind
Summary: yum update --downloadonly doesn't resume download, and leaves temp files behind
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: yum
Version: 7.3
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Michal Domonkos
QA Contact: Eva Mrakova
URL:
Whiteboard:
Depends On:
Blocks: 1477664 1630909 1630918
TreeView+ depends on / blocked
 
Reported: 2017-01-04 21:03 UTC by David Shaw
Modified: 2019-08-06 13:13 UTC (History)
7 users (show)

Fixed In Version: yum-3.4.3-162.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:13:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2286 0 None None None 2019-08-06 13:13:34 UTC

Description David Shaw 2017-01-04 21:03:48 UTC
Description of problem:

If "yum update --downloadonly" is interrupted or fails during download for some reason (bad network, etc), it leaves its temp files behind.  Unfortunately, when the command is run again, yum leaves these temp files in place rather than resuming them where it left off.

Worse, the temp files are never cleaned up.  Even "yum clean all" ignores them, so the space is lost.

Version-Release number of selected component (if applicable):

yum-3.4.3-150

How reproducible:

Every time.

Steps to Reproduce:
1.  Do a yum update --downloadonly
2.  Hit ctrl-C while it's mid download
3.  Run yum update --downloadonly again

Actual results:

Various #####.tmp files left behind in /var/cache/yum

Expected results:

No leftover temp files.

Additional info:

This seems identical to (fixed) Fedora bug 1045806.  Can that fix be applied to RHEL?

Comment 13 errata-xmlrpc 2019-08-06 13:13:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2286


Note You need to log in before you can comment on or make changes to this bug.