Bug 1410260 - ghostscript-8.70-21.el6_8.1.x86_64 update causes evince to not display postscript files.
Summary: ghostscript-8.70-21.el6_8.1.x86_64 update causes evince to not display postsc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ghostscript
Version: 6.8
Hardware: All
OS: All
urgent
urgent
Target Milestone: rc
: ---
Assignee: David Kaspar [Dee'Kej]
QA Contact: QE Internationalization Bugs
Lucie Maňásková
URL:
Whiteboard:
Depends On: 1411725
Blocks: 1411843
TreeView+ depends on / blocked
 
Reported: 2017-01-04 22:47 UTC by David Miller
Modified: 2020-05-14 15:31 UTC (History)
21 users (show)

Fixed In Version: ghostscript-8.70-23.el6
Doc Type: Release Note
Doc Text:
Evince now displays PostScript files again Due to a bug, the *evince* document viewer failed to display content of PostScript files. A patch has been applied and *evince* now displays PostSrcipt files again.
Clone Of:
Environment:
Last Closed: 2017-03-21 12:06:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
rhel7 gs_init.ps patch (667 bytes, patch)
2017-01-12 16:55 UTC, Rob Henderson
no flags Details | Diff
Patch that corrects the problem in CentOS 6 (416 bytes, patch)
2017-01-24 15:22 UTC, Robert Nichols
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0810 0 normal SHIPPED_LIVE ghostscript bug fix update 2017-03-21 12:53:02 UTC

Description David Miller 2017-01-04 22:47:11 UTC
Description of problem:

Evince will no longer display postscript files after the ghostscript-8.70-21.el6_8.1.x86_64 update. Evince gives the following error in the console

** (evince:14625): WARNING **: Error rendering thumbnail
invalidaccess -7

Version-Release number of selected component (if applicable):

ghostscript-8.70-21.el6_8.1

evince-2.28.2-19.el6

How reproducible:

happens to every .ps file I try to open.

Steps to Reproduce:
1. Launch evince either in command line or icon in GNOME.
2. open a postscript file with evince.

Actual results:

The evince window says loading...

Expected results:

Postscript file is displayed.

Additional info:

Comment 2 Rob Henderson 2017-01-09 16:06:22 UTC
I am seeing the same problem as the OP on RHEL 6.8.  In addition, I am also able to reproduce it with ghostscript-9.07-20.el7_3.1.x86_64 on RHEL 7.3:

$ evince try.ps
II 1
invalidaccess -7
invalidaccess -7
invalidaccess -7

On RHEL 7.3 the evince window comes up but the display is blank.  With RHEL 6.8 I also see the "Loading..." message.

It doesn't seem to be specific to any particular ps/eps file since I have see the same behavior with several different ps files from various sources.  I *am* able to display the files by running ghostscript directly but just not with evince.

Comment 3 Tom G. Christensen 2017-01-12 09:56:00 UTC
This was fixed upstream in June 2016:
http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=99e331527d541a8f01ad5455c4eb2aabd67281a6;hp=0d4644c003067fc14ca1db9c600dce420c06e6b1

I've verified that the upstream patch fixes the issue with evince on el6.

Comment 4 Rob Henderson 2017-01-12 16:55:40 UTC
Created attachment 1240027 [details]
rhel7 gs_init.ps patch

I have also verified that this fixes it on rhel7.  An ever-so-slight modification of the referenced patch that works on rhel7 version of gs_init.ps is attached.

Comment 5 Robert Nichols 2017-01-24 15:22:31 UTC
Created attachment 1243951 [details]
Patch that corrects the problem in CentOS 6

A slightly different modification of the referenced patch that works on CentOS 6 is attached.

Comment 18 Kent Engström 2017-02-02 16:41:53 UTC
Concerning the doc text "caused *evince* to stop displaying contents of PostScript files": Another regression seems to be that "ps2epsi file.ps" stopped working (with ugly backtraces). If that too is fixed (a patch of "put" -> ".forceput" in gs_init.ps fixed it for me), maybe it should be mentioned? Or at least  something to the effect that the evince display problems were not the only problems.

Comment 21 David Kaspar [Dee'Kej] 2017-02-03 13:25:04 UTC
(In reply to Kent Engström from comment #18)
> Concerning the doc text "caused *evince* to stop displaying contents of
> PostScript files": Another regression seems to be that "ps2epsi file.ps"
> stopped working (with ugly backtraces). If that too is fixed (a patch of
> "put" -> ".forceput" in gs_init.ps fixed it for me), maybe it should be
> mentioned? Or at least  something to the effect that the evince display
> problems were not the only problems.

I'm sorry, but I didn't understand exactly what you were saying.

Are you refering to any BZ already opened? Or is this something new you have encountered? And is it fixed by the patch for this BZ?

In case you have encountered a new bug, please, create a new bug report. We will then look at it and evaluate the options.

Thank you!

David

Comment 22 Kent Engström 2017-02-03 16:08:46 UTC
(In reply to David Kaspar [Dee'Kej] from comment #21)
> (In reply to Kent Engström from comment #18)
> 
> I'm sorry, but I didn't understand exactly what you were saying.
> 
> Are you refering to any BZ already opened? Or is this something new you have
> encountered? And is it fixed by the patch for this BZ?
> 
> In case you have encountered a new bug, please, create a new bug report. We
> will then look at it and evaluate the options.

I think I discovered the same regression bug that is discussed in this bugzilla entry, and that is fixed by the patch in comment #5 here. I also believe this is the same regression that is discussed in bz#1411843 and bz#1411725.

I got a report from a user at our site that "ps2epsi" had stopped working when we updated to ghostscript-8.70-21.el6_8.1.x86_64. When I manually applied the patch from comment #5 here, "psepsi" worked again.

So, as far as I am concerned, the bug will be fixed if you release a package that contains the patch. I just tried to help you write a better text for the release notes, by pointing out that the fix here solves regressions for more programs than just evince. Nothing more, nothing less :-)

Comment 25 David Kaspar [Dee'Kej] 2017-02-06 11:23:41 UTC
(In reply to Kent Engström from comment #22)
> (In reply to David Kaspar [Dee'Kej] from comment #21)
> I think I discovered the same regression bug that is discussed in this
> bugzilla entry, and that is fixed by the patch in comment #5 here. I also
> believe this is the same regression that is discussed in bz#1411843 and
> bz#1411725.
Actually, BZ #1411725 is de facto clone of this BZ for RHEL-7. However, the BZ #1411843 is much more complicated in that sense.

The patch in this BZ will fix the issue in BZ #1411843 only partially. After the fix, the conversion there will still not work, and most likely it never will be. I have discussed the issues about it already with upstream, and I will post my findings there soon.

> I got a report from a user at our site that "ps2epsi" had stopped working
> when we updated to ghostscript-8.70-21.el6_8.1.x86_64. When I manually
> applied the patch from comment #5 here, "psepsi" worked again.

Thank you for the information, Kent. It might be good to test this issue as well.

> So, as far as I am concerned, the bug will be fixed if you release a package
> that contains the patch. I just tried to help you write a better text for
> the release notes, by pointing out that the fix here solves regressions for
> more programs than just evince. Nothing more, nothing less :-)

I understand now. However, unless we have this confirmed by our devel/QE engineers, we can't make such guarantees in BZ documentation. I'm sorry about that.

Comment 34 errata-xmlrpc 2017-03-21 12:06:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0810.html


Note You need to log in before you can comment on or make changes to this bug.