Bug 1410270 - docker-compose-1.11.1 is available
docker-compose-1.11.1 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: docker-compose (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Hampton
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On: 1422198 1425461
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-04 19:18 EST by Upstream Release Monitoring
Modified: 2017-02-23 04:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-21 17:16:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (5.37 KB, patch)
2017-01-04 19:18 EST, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (5.37 KB, patch)
2017-01-12 19:12 EST, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (17.72 KB, patch)
2017-02-02 07:18 EST, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (19.00 KB, patch)
2017-02-09 07:15 EST, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (19.00 KB, patch)
2017-02-10 07:14 EST, Upstream Release Monitoring
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2017-01-04 19:18:14 EST
Latest upstream release: 1.10.0-rc1
Current version/release in rawhide: 1.9.0-3.fc26
URL: https://github.com/docker/compose

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6185/
Comment 1 Upstream Release Monitoring 2017-01-04 19:18:35 EST
Patching or scratch build for docker-compose-1.9.0 failed.
Comment 2 Upstream Release Monitoring 2017-01-04 19:18:36 EST
Created attachment 1237450 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 3 Upstream Release Monitoring 2017-01-04 19:18:38 EST
Patches were not touched. All were applied properly
Comment 4 Upstream Release Monitoring 2017-01-12 19:12:29 EST
Latest upstream release: 1.10.0-rc2
Current version/release in rawhide: 1.9.0-3.fc26
URL: https://github.com/docker/compose

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6185/
Comment 5 Upstream Release Monitoring 2017-01-12 19:12:55 EST
Patching or scratch build for docker-compose-1.9.0 failed.
Comment 6 Upstream Release Monitoring 2017-01-12 19:12:57 EST
Created attachment 1240148 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 7 Upstream Release Monitoring 2017-01-12 19:12:59 EST
Following patches has been deleted:
['console-setup-1.76-paths.patch', 'console-setup-1.76-fsf-address.patch']
Comment 8 Yajo 2017-01-21 06:30:39 EST
They released 1.10 final!: https://github.com/docker/compose/releases/tag/1.10.0
Comment 9 Upstream Release Monitoring 2017-02-02 07:18:08 EST
Latest upstream release: 1.10.1
Current version/release in rawhide: 1.9.0-3.fc26
URL: https://github.com/docker/compose

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6185/
Comment 10 Upstream Release Monitoring 2017-02-02 07:18:31 EST
Patching or scratch build for docker-compose-1.9.0 failed.
Comment 11 Upstream Release Monitoring 2017-02-02 07:18:33 EST
Created attachment 1247102 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 12 Upstream Release Monitoring 2017-02-02 07:18:35 EST
Patches were not touched. All were applied properly
Comment 13 Michael Hampton 2017-02-03 04:07:57 EST
Requires python-docker-py 2.0.2, which is not yet packaged in Fedora.
Comment 14 Tomas Tomecek 2017-02-09 03:40:32 EST
Since docker-py changed API, I'm not sure if we can safely just update it in rawhide or we want a compat package. The list of packages using docker-py is actually quite short: atomic, docker-compose, flr, atomic-reactor, docker-squash, sen. So I might start with testing whether all the packages work with latest docker-py and then update it in rawhide so we have docker-compose 1.10 in F26.

Any suggestions, Michael?
Comment 15 Upstream Release Monitoring 2017-02-09 07:14:58 EST
Latest upstream release: 1.11.0
Current version/release in rawhide: 1.9.0-3.fc26
URL: https://github.com/docker/compose

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6185/
Comment 16 Upstream Release Monitoring 2017-02-09 07:15:21 EST
Patching or scratch build for docker-compose-1.9.0 failed.
Comment 17 Upstream Release Monitoring 2017-02-09 07:15:24 EST
Created attachment 1248797 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 18 Upstream Release Monitoring 2017-02-09 07:15:27 EST
Following patches has been deleted:
['remove-requires-upper-bound.patch']
Comment 19 Michael Hampton 2017-02-09 14:24:08 EST
(In reply to Tomas Tomecek from comment #14)
> Since docker-py changed API, I'm not sure if we can safely just update it in
> rawhide or we want a compat package. The list of packages using docker-py is
> actually quite short: atomic, docker-compose, flr, atomic-reactor,
> docker-squash, sen. So I might start with testing whether all the packages
> work with latest docker-py and then update it in rawhide so we have
> docker-compose 1.10 in F26.

More like 1.11 it seems.

Anyway, are you sure about docker-squash? That seems to be a pure Go application without any Python dependencies, or any other dependencies at all except for golang and tar.

If docker-py broke backward compatibility then I'm fine with updating in rawhide only. It would unfortunately not be the first time, and doubly unfortunately docker doesn't use semver to make these breaks visible.

Ultimately the issue is that upstream is releasing very fast, and we're not keeping up. Not just with docker-compose or python-docker-py, but with docker and pretty much everything else they write.

So I'd like to see a couple of things:

 1. That we encourage upstream to begin using semantic versioning.
 2. That we figure out how closely Fedora should track updates to Docker and its associated packages such as python-docker-py, docker-compose, etc.
Comment 20 Tomas Tomecek 2017-02-10 05:10:03 EST
(In reply to Michael Hampton from comment #19)
> More like 1.11 it seems.

Oh, you're right. I lost track.

> Anyway, are you sure about docker-squash? That seems to be a pure Go
> application without any Python dependencies, or any other dependencies at
> all except for golang and tar.

Overload... You're right there is docker-squash written in go, but at the same
time there is also docker-squash written in python, done by Marek Goldmann:

https://github.com/goldmann/docker-squash
https://admin.fedoraproject.org/pkgdb/package/rpms/python-docker-squash/

> If docker-py broke backward compatibility then I'm fine with updating in
> rawhide only. It would unfortunately not be the first time, and doubly
> unfortunately docker doesn't use semver to make these breaks visible.

I think they did it right this time:

  MAJOR version when you make incompatible API changes,

http://semver.org/#summary

They bumped from 1.x to 2.x.

On the flipside, I agree that sometimes compatibility gets broken when issuing
minor releases.

> Ultimately the issue is that upstream is releasing very fast, and we're not
> keeping up. Not just with docker-compose or python-docker-py, but with
> docker and pretty much everything else they write.
> 
> So I'd like to see a couple of things:
> 
>  1. That we encourage upstream to begin using semantic versioning.
>  2. That we figure out how closely Fedora should track updates to Docker and
> its associated packages such as python-docker-py, docker-compose, etc.

I already tried to push them to improve some packaging habits, but it had no effect.

To your second point: it would be awesome if automation helped us with that,
not sure if it's feasible.
Comment 21 Upstream Release Monitoring 2017-02-10 07:14:25 EST
Latest upstream release: 1.11.1
Current version/release in rawhide: 1.9.0-3.fc26
URL: https://github.com/docker/compose

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6185/
Comment 22 Upstream Release Monitoring 2017-02-10 07:14:48 EST
Patching or scratch build for docker-compose-1.9.0 failed.
Comment 23 Upstream Release Monitoring 2017-02-10 07:14:50 EST
Created attachment 1249026 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 24 Upstream Release Monitoring 2017-02-10 07:14:53 EST
Following patches has been deleted:
['remove-requires-upper-bound.patch']
Comment 25 Upstream Release Monitoring 2017-02-10 17:33:20 EST
error's docker-compose-1.11.1-1.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=845014
Comment 26 Michael Hampton 2017-02-10 17:38:44 EST
(In reply to Tomas Tomecek from comment #20)
> They bumped from 1.x to 2.x.
> 
> On the flipside, I agree that sometimes compatibility gets broken when
> issuing minor releases.

I hope they continue to use semver, then!

> I already tried to push them to improve some packaging habits, but it had no
> effect.
> 
> To your second point: it would be awesome if automation helped us with that,
> not sure if it's feasible.

Compose has a test suite, but it requires being able to spawn a copy of Docker and start containers within it. AFAIK you can't run Docker inside a mock chroot. If there _is_ a way to do that, I would love to know about it. Of course, then it requires network access to download container images, too... so that's still going to be a pain.
Comment 27 Tomas Tomecek 2017-02-16 05:39:33 EST
Just FYI, we should have d-py 2 in rawhide soon:

https://bugzilla.redhat.com/show_bug.cgi?id=1422198
Comment 28 Upstream Release Monitoring 2017-02-21 17:15:51 EST
error's docker-compose-1.11.1-2.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=860806

Note You need to log in before you can comment on or make changes to this bug.