Bug 1410286 - Docker port in atomic client configuration package
Summary: Docker port in atomic client configuration package
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: RHUI Bug List
QA Contact: Vratislav Hutsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 01:13 UTC by Irina Gulina
Modified: 2017-01-05 15:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-05 15:04:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Irina Gulina 2017-01-05 01:13:13 UTC
Description of problem:
'create a client configuration RPM' doesn't ask a user to specify port to serve Docker content on, and there is a separate option to 'create a docker client configuration RPM'. Meanwhile 'create an atomic client configuration package' asks to specify a port to serve Docker content on. Apparently, it shouldn't.

Version-Release number of selected component (if applicable):
iso 20161220

How reproducible:
always

Steps to Reproduce:
1. e   generate an entitlement certificate
2. o   create an atomic client configuration package


Actual results:
rhui (client) => o

Full path to local directory in which the client configuration files generated by this tool
should be stored (if this directory does not exist, it will be created):
/tmp/

Name of the tar file (excluding extension):
atomic_pkg

Full path to the entitlement certificate authorizing the client to access
specific channels:
/tmp/cert_0105.crt

Full path to the private key for the above entitlement certificate:
/tmp/cert_0105.key

Port to serve Docker content on (default 5000):


Successfully created client configuration package.
Package tar file can be found at /tmp/

Comment 3 Radek Bíba 2017-01-05 07:35:08 UTC
Why not? The tarball then contains these commands:

mkdir -p /etc/docker/certs.d/cds.example.com:5000
cp ./ca.crt /etc/docker/certs.d/cds.example.com:5000/ca.crt
sed -i '/ADD_REGISTRY/s/=.*/='"'"'--add-registry cds.example.com:5000'"'"'/' /etc/sysconfig/docker

This looks like a feature to me.

Comment 4 Radek Bíba 2017-01-05 07:35:38 UTC
I mean, install.sh in the tarball contains those commands.

Comment 5 Irina Gulina 2017-01-05 13:07:51 UTC
And if the entitlement cert doesn't contain any docker repo?

And some time ago 'c - create a client configuration RPM' also contained that Docker port, but after 'd - create a docker client configuration RPM' was added, it was removed from 'c'. Do you remember you corrected the lib for client conf rpm creation because of that? Commit b2a6bcb.

Comment 6 Radek Bíba 2017-01-05 13:28:11 UTC
There are no docker "repos" to include in an entitlement cert (and that's why the docker workflow was split and the test suite was adjusted). Docker containers are mirrored from the Red Hat and served on <haproxy_host>:<port> (port=5000 by default). You don't necessarily have to have a docker container in your RHUI, but my understanding is that it's good to prepare the configuration on the atomic host in case you ever start serving docker containers. Engineering could tell you why they put the prompt for the docker port to the atomic tar creation.

Comment 7 Patrick Creech 2017-01-05 14:21:43 UTC
Radek is correct.

The atomic host has docker pre-installed as one of atomic host's primary functions is to host docker containers.

So, to recap:

1) We moved docker to it's own client config setup for client config RPMs by design.

2) We included docker in the atomic host config package as atomic hosts can host docker images as well.

Comment 8 Irina Gulina 2017-01-05 15:04:55 UTC
Patrick, thanks for the clarification.


Note You need to log in before you can comment on or make changes to this bug.