Bug 141032 - Crash on reply - highlighting included mail
Summary: Crash on reply - highlighting included mail
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-28 18:02 UTC by gene c
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 20:22:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 269986 None None None Never

Description gene c 2004-11-28 18:02:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:

Evolution - runnign under kde - fc3 fully yum updated.

Imap mail. Reply - attempt to highlight included email and the
signature thereof - boom crash burn.

Happens every time.

No apparent data loss but makes evolution substantially less usefulf
for responding to email!

Filed in upstream as well:
http://bugzilla.gnome.org/show_bug.cgi?id=159736

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Reply to email
2.Highlight included text+sig
3.
    

Actual Results:  Crash -> bug buddy

Expected Results:  Errm .. not crash?

Additional info:

Comment 1 gene c 2004-11-28 19:53:52 UTC
Bug buddy filed bug as above - gnome.org asked this to be refiled in
ximian buugzilla: Done - now filed upstream 

 http://bugzilla.ximian.com/show_bug.cgi?id=69986

g/

Comment 2 gene c 2004-11-28 22:05:07 UTC
Further - it appears that the problem is needs a signature to trigger
it - both in the included text and possibly also the auto signature of
the sender. 

And, I have not yet tried when running under gnome.

g/

Comment 3 Dave Malcolm 2004-11-29 21:14:17 UTC
Does it work if you run it under GNOME?

Comment 4 gene c 2004-11-30 02:42:18 UTC
No - it crashes the same way under both KDE and Gnome - I posted a
sample mail upstream which does it for me.

Regards,

g/


Comment 5 Bob Gustafson 2004-12-02 16:20:59 UTC
Another crash situation - may be related.

FC3 - updated - running Gnome

How to
1) Open Evolution - go to mail
2) New-> create a blank email
3) Paste in text (haven't zeroned in on the size required, but enough
to cause scrollbar to be active (more than one viewport worth).
3) At the end of the paste, you are seeing the end of the pasted text.
Using the scrollbar, slowly (or fast..) scroll up so you can see the
top of the text.

4) Boom crash blinkout. You will never see the beginning of the pasted
text. No trace of message in drafts or ... when you restart evolution.

Looks like a buffer problem.

Comment 6 Dave Malcolm 2004-12-02 16:52:03 UTC
Please can you ensure that the gtkhtml3-debuginfo package is
installed, generate a stack backtrace, and attach to this bug; see
this page for more information:
http://fedora.linux.duke.edu/wiki/index.cgi/StackTraces

Thanks


Note You need to log in before you can comment on or make changes to this bug.