Bug 1410330 - setup_package_repos in RHUI 3.0 Beta 2 for RHEL 7 ISO doesn't import beta gpg key. It causes failure of 'yum -y rhui-installer'.
Summary: setup_package_repos in RHUI 3.0 Beta 2 for RHEL 7 ISO doesn't import beta gpg...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Documentation
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.0.0
Assignee: Les Williams
QA Contact: Radek Bíba
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 07:28 UTC by Keigo Noha
Modified: 2017-03-01 22:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-01 22:15:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0367 0 normal SHIPPED_LIVE Red Hat Update Infrastructure 3.0 Release 2017-03-02 03:05:22 UTC

Description Keigo Noha 2017-01-05 07:28:19 UTC
Description of problem:
setup_package_repos in RHUI 3.0 Beta 2 for RHEL 7 ISO doesn't import beta gpg key. It prevent to install 'yum -y rhui-installer'.

Version-Release number of selected component (if applicable):
setup_package_repos in RHUI 3.0 Beta 2 for RHEL 7 ISO

How reproducible:
Always.

Steps to Reproduce:
1. Run ./setup_package_repos
2. Run yum -y rhui-installer
3.

Actual results:
Packages in local rhui repository can not be installed.

Expected results:
Packages in local rhui repository can be installed successfully.

Additional info:
setup_package_repos in RHUI 3.0 Beta 2 for RHEL 7 ISO contains following definition.

~~~
# Figure out where we are running
INSTALL_FILE = os.path.abspath(__file__)
PWD = os.path.dirname(INSTALL_FILE)
GPG_FILE="/etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release"
REPO_FILE = "/etc/yum.repos.d/rhui-local.repo"
DEST_DIR = "/opt/rhui/"
~~~

GPG_FILE needs to point /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta because RHUI3.0 is still in beta.

Workaround:
Manual import with 'rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta' resolve this issue.

Comment 10 errata-xmlrpc 2017-03-01 22:15:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0367


Note You need to log in before you can comment on or make changes to this bug.