Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1410375 - [Mdcache] clients being served wrong information about a file, can lead to file inconsistency
Summary: [Mdcache] clients being served wrong information about a file, can lead to fi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1409808
Blocks: 1410688
TreeView+ depends on / blocked
 
Reported: 2017-01-05 11:03 UTC by Poornima G
Modified: 2017-03-06 17:42 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1409808
: 1410688 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:42:42 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-01-05 11:04:07 UTC
REVIEW: http://review.gluster.org/16329 (ec: Invalidations in disperse volume should not update the stat) posted (#3) for review on master by Poornima G (pgurusid@redhat.com)

Comment 2 Worker Ant 2017-01-06 05:12:23 UTC
COMMIT: http://review.gluster.org/16329 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 95d07a3d2d68805d93d36a447436e27c48777939
Author: Poornima G <pgurusid@redhat.com>
Date:   Thu Jan 5 15:36:02 2017 +0530

    ec: Invalidations in disperse volume should not update the stat
    
    Issue:
    In disperse volume, the file is present across bricks, hence the stat
    from one brick doesn't carry the valid size of the file. Therefore
    the upcall from one brick updating the md-cache results in wrong size
    being updated.
    
    Fix:
    If the notification is cache invalidation then, indicate md-cache that
    the attributes is invalid.
    
    BUG: 1410375
    Change-Id: Id89d2283478e70b62b435a8891fffc86d2be8cb2
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/16329
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 3 Shyamsundar 2017-03-06 17:42:42 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.