Bug 141039 - When "enabled=0", yum will still fetch a "mirrorlist".
When "enabled=0", yum will still fetch a "mirrorlist".
Status: CLOSED DUPLICATE of bug 140143
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-28 13:36 EST by Terje Bless
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terje Bless 2004-11-28 13:36:05 EST
If for a given repo you set "enabled=0" -- e.g. to force the use of
FTP cf. Bug #138535 -- and that repo has a "mirrorlist" defined, yum
will attempt to fetch the given mirrorlist if no enabled repo has one
defined (i.e. it has only "baseurl" defined).

e.g. on a default yum-2.1.11-4 install in Rawhide, if you...

1. delete the "fedora-updates" and "fedora-updates-testing" repos,
2. set the "fedora" repo to "enabled=0",
3. for "fedora-devel", remove the "mirrorlist" and set an (FTP)
   "baseurl" instead

...yum will try to fetch the "mirrorlist" URL given for "fedora"
despite the repo being disabled. In current versions this means it
will produce a traceback due to Bug #138535, but even with the
Python issue fixed this behaviour is undesireable.
Comment 1 Seth Vidal 2004-11-30 00:48:30 EST

*** This bug has been marked as a duplicate of 140143 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.