Bug 14104 - text-utils display all wrong when run in gnome
text-utils display all wrong when run in gnome
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-17 05:06 EDT by Telsa Gwynne
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-17 10:54:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jpg showing weird display of textmode tools in GNOME (21.86 KB, image/jpeg)
2000-07-17 05:07 EDT, Telsa Gwynne
no flags Details

  None (edit)
Description Telsa Gwynne 2000-07-17 05:06:16 EDT
I should not have seen 'textmode utilities' as a menu
option when running GNOME as non-root, but I did, 
so had to try it out. The display is wrong. This may
be X, GNOME, or textutils itself: I am not competent
to judge. 

jpg attached (I hope). Look at the borders, with YYY
UUU RRR all around the edges.
Comment 1 Telsa Gwynne 2000-07-17 05:07:38 EDT
Created attachment 1209 [details]
jpg showing weird display of textmode tools in GNOME
Comment 2 Bernhard Rosenkraenzer 2000-07-17 07:04:36 EDT
This has nothing to do with textutils (that package contains cat, cksum, sort
and stuff).
The screenshot shows the setup program from the setuptool package; since it uses
normal newt library calls to generate its interface, it seems to be a problem
with newt or gnome-terminal.
Comment 3 David Mason 2000-07-17 10:40:43 EDT
hp - can you see if this is gnome-terminal related?
Comment 4 Telsa Gwynne 2000-07-17 10:54:52 EDT
Yeah, I'm stupid. I do know what textutils is when I'm awake.
Additional info and suggestion: I changed various themes and
fonts to try and shrink the size of things on my 640x480 display. 
Suggestion is that the font I picked can't display fancy characters 
and is producing the garbage instead.  Font name was 'clean', I 
believe: shows up as
[hobbit@trouble hobbit]$ grep -i font .gnome/*
.gnome/Terminal:font=-schumacher-clean-medium-r-normal-*-*-100-*-*-c-*-iso646.1991-irv
.gnome/gnome-terminal-AwCDcN:font=-schumacher-clean-medium-r-normal-*-*-100-*-*-c-*-iso646.1991-irv
.gnome/gnome-terminal-ak7PLR:font=-schumacher-clean-medium-r-normal-*-*-100-*-*-c-*-iso646.1991-irv
.gnome/theme-switcher-capplet:use_theme_font=true
.gnome/theme-switcher-capplet:font=-schumacher-clean-medium-r-normal-*-*-100-*-*-c-*-iso646.1991-irv

Any help?
Comment 5 Havoc Pennington 2000-07-24 12:12:21 EDT
I think newt just uses those funny characters if the font lacks the 
border characters. Not much else it could do, maybe there are more attractive 
fallback characters it could use.

Note You need to log in before you can comment on or make changes to this bug.