Bug 1410405 - unexpected TAB order in the external network subnet window
Summary: unexpected TAB order in the external network subnet window
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: future
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ovirt-4.1.1
: 4.1.1.3
Assignee: Marcin Mirecki
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 12:28 UTC by Mor
Modified: 2017-04-21 09:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:52:58 UTC
oVirt Team: Network
rule-engine: ovirt-4.1+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71150 0 master MERGED webadmin: unexpected TAB order in the external network subnet window 2017-02-07 20:33:25 UTC
oVirt gerrit 72012 0 ovirt-engine-4.1 MERGED webadmin: unexpected TAB order in the external network subnet window 2017-02-12 09:02:22 UTC

Description Mor 2017-01-05 12:28:54 UTC
Description of problem:

Pressing the TAB key in the subnet creation window, moves the cursor to the incorrect text-box.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 4.2.0-0.0.master.20170104122709.gitf219a7d.el7.centos

How reproducible:
100%

Steps to Reproduce:
1. Create external network on network provider.
2. Select the name text-box (first one in order).
3. Press tab.

Actual results:
The cursor moved to the last text-box.

Expected results:
It should be on the second text-box (CIDR).

Additional info:
UX bug.

Comment 1 Marcin Mirecki 2017-01-24 14:52:32 UTC
The tab order is set in:
https://github.com/oVirt/ovirt-engine/blob/master/frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/provider/ProviderPopupView.java#L256

com.google.gwt.event.dom.client.KeyPressEvent is a good start for debugging

Comment 2 Mor 2017-02-19 12:57:51 UTC
Failed to verify the patch on version: Red Hat Virtualization Manager Version: 4.1.1.2-0.1.el7. Seems like the code isn't backported to RHV.

Comment 3 Red Hat Bugzilla Rules Engine 2017-02-19 12:57:58 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 4 Mor 2017-02-20 15:14:01 UTC
Verified on version: Red Hat Virtualization Manager Version: 4.1.1.2-0.1.el7


Note You need to log in before you can comment on or make changes to this bug.