Bug 1410409 - oscap-docker incorrectly informs about incompliance of the assessed system
Summary: oscap-docker incorrectly informs about incompliance of the assessed system
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openscap
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Raphael Sanchez Prudencio
QA Contact: Marek Haicman
Mirek Jahoda
URL:
Whiteboard:
Depends On: 1387248
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 12:34 UTC by Marcel Kolaja
Modified: 2020-04-15 15:03 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In a case of a successful scan of an incompliant system, the oscap-docker command-line utility incorrectly reported an error. With this update, oscap-docker correctly assesses incompliant systems and prints which rules did not pass the scan to the evaluation results.
Clone Of: 1387248
Environment:
Last Closed: 2017-03-02 17:12:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github OpenSCAP openscap issues 475 0 None closed Inform better that a container/image does not comply to a benchmark 2020-04-20 11:52:13 UTC
Red Hat Product Errata RHBA-2017:0380 0 normal SHIPPED_LIVE openscap bug fix update 2017-03-02 22:05:33 UTC

Description Marcel Kolaja 2017-01-05 12:34:36 UTC
This bug has been copied from bug #1387248 and has been proposed
to be backported to 7.3 z-stream (EUS).

Comment 5 Marek Haicman 2017-02-11 19:06:13 UTC
Verified that version openscap-utils-1.2.10-3.el7_3.x86_64 fixes the issue. No regressions identified.

Comment 7 errata-xmlrpc 2017-03-02 17:12:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0380.html


Note You need to log in before you can comment on or make changes to this bug.