Bug 1410413 - not all dependant repos exist for ppc64le
Summary: not all dependant repos exist for ppc64le
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-release
Classification: oVirt
Component: General
Version: 4.1.0
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.1.0-rc
: 4.1.0
Assignee: Sandro Bonazzola
QA Contact: Jiri Belka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 12:39 UTC by Evgheni Dereveanchin
Modified: 2019-04-28 14:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-02-15 15:00:32 UTC
oVirt Team: Integration
rule-engine: ovirt-4.1+
rule-engine: blocker+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71191 0 master MERGED el7: split x86_64 and ppc64le deps 2017-01-26 09:29:24 UTC
oVirt gerrit 71227 0 ovirt-4.1 MERGED el7: split x86_64 and ppc64le deps 2017-01-26 09:43:33 UTC

Description Evgheni Dereveanchin 2017-01-05 12:39:16 UTC
Description of problem:
VDSM is built for the ppc64le arch and the release RPM is supposed to let users install all required packages. When installed on a ppc64le CentOS 7 machine however, some repos like Gluster, opstools and patternfly will fail to work

Version-Release number of selected component (if applicable):
http://resources.ovirt.org/pub/yum-repo/ovirt-release41-pre.rpm

How reproducible:


Steps to Reproduce:
1. install minimal CentOS 7.3 ppc64le to act as an oVirt hypervisor
2. yum install http://resources.ovirt.org/pub/yum-repo/ovirt-release41-pre.rpm
3. yum update

Actual results:
...
 http://buildlogs.centos.org/centos/7/opstools/ppc64le/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
...
 http://mirror.centos.org/centos/7/storage/ppc64le/gluster-3.8/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
...
 http://copr-be.cloud.fedoraproject.org/results/patternfly/patternfly1/epel-7-ppc64le/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
...

Expected results:
Unneeded repos not enabled (patternfly/opstools don't seem necessary on hypervisors), needed ones are ported to ppc64le

Comment 1 Evgheni Dereveanchin 2017-01-25 13:48:05 UTC
Just wanted to update you that in 4.1-RC1 the behavior is similar:

http://buildlogs.centos.org/centos/7/opstools/ppc64le/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
http://mirror.centos.org/centos/7/storage/ppc64le/gluster-3.8/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

The patternfly repo does not return errors any more even though I don't see el7 ppc64le builds on COPR. Here's what is defined in the repo file:

baseurl=http://copr-be.cloud.fedoraproject.org/results/patternfly/patternfly1/epel-7-$basearch/

Comment 2 Jiri Belka 2017-02-02 12:04:37 UTC
ok for ovirt repos...

... but there's missing up-to-date libvirt-daemon-kvm for 4.1 vdsm for ppc64le from altarch group, thus vdsm is not installable. (it's because all vdsm require libvirt-daemon-kvm >= 2.0.0-10.el7_3.4, compared with x86_64 vdsm.)

we don't own centos thus new BZ for centos was submitted https://bugs.centos.org/view.php?id=12768

--> Processing Dependency: libvirt-daemon-kvm >= 2.0.0-10.el7_3.4 for package: vdsm-4.19.4-1.el7.centos.ppc64le
--> Finished Dependency Resolution
Error: Package: vdsm-4.19.4-1.el7.centos.ppc64le (ovirt-4.1)
           Requires: libvirt-daemon-kvm >= 2.0.0-10.el7_3.4
           Available: libvirt-daemon-kvm-2.0.0-10.el7.ppc64le (base)
               libvirt-daemon-kvm = 2.0.0-10.el7
           Available: libvirt-daemon-kvm-2.0.0-10.el7_3.2.ppc64le (updates)
               libvirt-daemon-kvm = 2.0.0-10.el7_3.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

(tested with qemu-system-ppc64le)


Note You need to log in before you can comment on or make changes to this bug.