Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1410431 - HE VM update via webadmin does not work
Summary: HE VM update via webadmin does not work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-4.1.0-beta
: 4.1.0.2
Assignee: Phillip Bailey
QA Contact: Artyom
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 13:28 UTC by Artyom
Modified: 2017-02-01 14:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Fields that are not editable for the hosted engine VM were not being cloned during the update process. Consequence: The HE VM update failed validation even when the only fields that were updated were valid fields. Fix: Add the missing fields to the cloner. Result: The HE VM now updates properly.
Clone Of:
Environment:
Last Closed: 2017-02-01 14:50:37 UTC
oVirt Team: SLA
rule-engine: ovirt-4.1+
rule-engine: blocker+
rule-engine: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 69861 0 master MERGED webadmin: Add quotaId and quotaName to Cloner 2017-01-09 15:40:50 UTC
oVirt gerrit 69869 0 ovirt-engine-4.1 MERGED webadmin: Add quotaId and quotaName to Cloner 2017-01-09 22:24:59 UTC

Description Artyom 2017-01-05 13:28:40 UTC
Description of problem:
Update the HE VM number of CPU or amount of the memory show me:
Error while executing action: 

HostedEngine:
There was an attempt to change Hosted Engine VM values that are locked.

Version-Release number of selected component (if applicable):
rhevm-4.1.0-0.3.beta2.el7.noarch

2017-01-05 08:27:36,746-05 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-27) [40aeb9bd-9c4e-4248-b4f6-54b348f7abd6] Lock Acquired to object 'EngineLock:{exclusiveLocks='[HostedEngine=<VM_NAME, ACTION_TYPE_FAILED_VM_IS_BEING_UPDATED>]', sharedLocks='[2f08cbe0-eff3-414f-a162-1ed6a2c21f12=<VM, ACTION_TYPE_FAILED_VM_IS_BEING_UPDATED>]'}'
2017-01-05 08:27:36,747-05 WARN  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-27) [40aeb9bd-9c4e-4248-b4f6-54b348f7abd6] Validation of action 'UpdateVm' failed for user admin@internal-authz. Reasons: VAR__ACTION__UPDATE,VAR__TYPE__VM,VM_CANNOT_UPDATE_HOSTED_ENGINE_FIELD
2017-01-05 08:27:36,747-05 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-27) [40aeb9bd-9c4e-4248-b4f6-54b348f7abd6] Lock freed to object 'EngineLock:{exclusiveLocks='[HostedEngine=<VM_NAME, ACTION_TYPE_FAILED_VM_IS_BEING_UPDATED>]', sharedLocks='[2f08cbe0-eff3-414f-a162-1ed6a2c21f12=<VM, ACTION_TYPE_FAILED_VM_IS_BEING_UPDATED>]'}

How reproducible:
Always

Steps to Reproduce:
1. Deploy HE on the host
2. Add storage domain to the engine to initialize the auto-import operation
3. Try to edit the HE VM memory or CPU.

Actual results:
Error while executing action: 

HostedEngine:
There was an attempt to change Hosted Engine VM values that are locked.

Expected results:
Update succeed

Additional info:
Update via REST works fine
# engine-config -g AllowEditingHostedEngine
AllowEditingHostedEngine: true version: general

Comment 1 Red Hat Bugzilla Rules Engine 2017-01-05 15:57:51 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Artyom 2017-01-24 11:31:46 UTC
Verified on rhevm-4.1.0.2-0.1.el7.noarch


Note You need to log in before you can comment on or make changes to this bug.