Bug 1410439 - glusterfind pre output file is empty
Summary: glusterfind pre output file is empty
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterfind
Version: mainline
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Shwetha K Acharya
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1410377 1790428 1790445
TreeView+ depends on / blocked
 
Reported: 2017-01-05 13:46 UTC by Milind Changire
Modified: 2020-01-13 11:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1410377
: 1790428 1790445 (view as bug list)
Environment:
Last Closed: 2019-10-31 14:32:54 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 16332 None Merged tools/glusterfind: handle offline bricks 2019-10-31 14:32:53 UTC

Comment 1 Milind Changire 2017-01-05 13:54:26 UTC
The BZ is a result of the "sort -u" failing due to a missing file. "sort -u" is run on the collected files if the --full argument is passed in "pre" and "query" modes.

Since the file couldn't be copied from the node on which a remove-brick was in progress, "sort" finds it missing on the local node and bails out with an error.

Comment 2 Worker Ant 2017-01-05 14:18:24 UTC
REVIEW: http://review.gluster.org/16332 (tools/glusterfind: handle offline bricks) posted (#1) for review on master by Milind Changire (mchangir@redhat.com)

Comment 3 Worker Ant 2017-01-05 14:23:47 UTC
REVIEW: http://review.gluster.org/16332 (tools/glusterfind: handle offline bricks) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)

Comment 4 Shwetha K Acharya 2019-09-03 06:44:08 UTC
REVIEW: https://review.gluster.org/#/c/glusterfs/+/16332/

Comment 5 Worker Ant 2019-10-31 14:22:04 UTC
REVIEW: https://review.gluster.org/16332 (tools/glusterfind: handle offline bricks) posted (#6) for review on master by Aravinda VK

Comment 6 Worker Ant 2019-10-31 14:32:54 UTC
REVIEW: https://review.gluster.org/16332 (tools/glusterfind: handle offline bricks) merged (#7) on master by Aravinda VK


Note You need to log in before you can comment on or make changes to this bug.