Bug 1410448 (CVE-2016-10046) - CVE-2016-10046 ImageMagick: Buffer overflow in draw.c
Summary: CVE-2016-10046 ImageMagick: Buffer overflow in draw.c
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2016-10046
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20160804,repor...
Depends On: 1410515
Blocks: 1410453
TreeView+ depends on / blocked
 
Reported: 2017-01-05 14:04 UTC by Andrej Nemec
Modified: 2019-06-08 21:41 UTC (History)
13 users (show)

Fixed In Version: ImageMagick 6.9.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-22 04:26:55 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2017-01-05 14:04:47 UTC
A heap-buffer overflow vulnerability was found in ImageMagick. A maliciously crafted image could cause the application to crash or have other unspecified impact.

References:

http://seclists.org/oss-sec/2016/q4/758
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=833730

Upstream patch:

https://github.com/ImageMagick/ImageMagick/commit/989f9f88ea6db09b99d25586e912c921c0da8d3f

Comment 1 Andrej Nemec 2017-01-05 16:12:37 UTC
Created ImageMagick tracking bugs for this issue:

Affects: fedora-all [bug 1410515]


Note You need to log in before you can comment on or make changes to this bug.