Bug 1410455 - tooltip over CPU number in VM General tab stays visible
Summary: tooltip over CPU number in VM General tab stays visible
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.1.2
: ---
Assignee: Greg Sheremeta
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 14:30 UTC by Lucie Leistnerova
Modified: 2017-04-01 20:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-01 20:05:52 UTC
oVirt Team: UX
rule-engine: ovirt-4.1+


Attachments (Terms of Use)
visible tooltip (94.16 KB, image/png)
2017-01-05 14:30 UTC, Lucie Leistnerova
no flags Details

Description Lucie Leistnerova 2017-01-05 14:30:29 UTC
Created attachment 1237688 [details]
visible tooltip

Description of problem:
Sometimes tooltip in VM General tab over number of CPU cores stays visible  - e.g. 1 (1:1:1), even if I move the mouse away.


Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.1.0-0.4.master.20170104122005.git51b1bcf.el7.centos.noarch

How reproducible: sometimes, when the tooltip is shown between some calling of the script GenericApiGWTService


Steps to Reproduce:
1. have 2 VMs created, not running
2. click on one VM in Virtual Machines tab, so the General tab is shown
3. open Developer tool at Network tab, script /ovirt-engine/webadmin/GenericApiGWTService is called periodically in doubles
4. when GenericApiGWTService is called first from the double, move mouse to the number of CPUs so the tooltip is shown
5. wait until GenericApiGWTService is called 2x (so the first call from the next double is called) and then move the mouse away from the number of CPUs

Actual results: tooltip stays visible, see attachment


Expected results: tooltip hides when I move the mouse away


Additional info:
tested in Firefox 50.1.0

Comment 1 Greg Sheremeta 2017-01-23 15:18:48 UTC
Won't make 4.1. Moving to 4.1.1

Comment 2 Greg Sheremeta 2017-04-01 20:05:52 UTC
I couldn't duplicate on master.

I think this bug is trivial enough that we don't need to spend time on it. The tooltip system isn't perfect due to a mix of technologies we use. It is possible to have race conditions where sometimes a tooltip gets stuck open. While possible, it is very rare. I'm very happy with the current performance.

Closing wontfix.


Note You need to log in before you can comment on or make changes to this bug.