Bug 1410464 (CVE-2016-10055) - CVE-2016-10055 ImageMagick: Buffer overflow in PDB coder
Summary: CVE-2016-10055 ImageMagick: Buffer overflow in PDB coder
Status: CLOSED WONTFIX
Alias: CVE-2016-10055
Product: Security Response
Classification: Other
Component: vulnerability   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20160823,repor...
Keywords: Security
Depends On: 1410515
Blocks: 1410453
TreeView+ depends on / blocked
 
Reported: 2017-01-05 14:56 UTC by Andrej Nemec
Modified: 2017-11-22 04:28 UTC (History)
13 users (show)

Fixed In Version: ImageMagick 6.9.5
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-22 04:28:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrej Nemec 2017-01-05 14:56:20 UTC
A buffer overflow vulnerability was found in ImageMagick in the coders/pdb.c file. A maliciously crafted file could cause the application to crash or possibly have other impact.

References:

http://seclists.org/oss-sec/2016/q4/758
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=836172

Upstream patch:

https://github.com/ImageMagick/ImageMagick/commit/10b3823a7619ed22d42764733eb052c4159bc8c1

Comment 1 Andrej Nemec 2017-01-05 16:13:58 UTC
Created ImageMagick tracking bugs for this issue:

Affects: fedora-all [bug 1410515]


Note You need to log in before you can comment on or make changes to this bug.