Bug 1410524 - Review Request: gala - Gala window manager
Summary: Review Request: gala - Gala window manager
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PantheonDesktopPackageReviews
TreeView+ depends on / blocked
 
Reported: 2017-01-05 16:22 UTC by Fabio Valentini
Modified: 2017-11-11 17:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-07 21:50:09 UTC
Type: ---
ngompa13: fedora-review+


Attachments (Terms of Use)

Description Fabio Valentini 2017-01-05 16:22:55 UTC
Spec URL: https://raw.githubusercontent.com/decathorpe/fedora-packaging/7c627929d6fc7db9f255ff45df19d5e20a7cd486/specs/gala/gala.spec

SRPM URL: https://copr-be.cloud.fedoraproject.org/results/decathorpe/staging/fedora-25-x86_64/00495947-gala/gala-0.3.0-0.bzr552.1.fc25.src.rpm

Description: Gala is Pantheon's Window Manager, part of the elementary project.

Fedora Account System Username: decathorpe


koji scratch build for rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=17169277

COPR build for rawhide and f25: https://copr.fedorainfracloud.org/coprs/decathorpe/staging/build/495947/

This package was already available via my elementary-stable/nightly COPR repository.

Comment 1 Neal Gompa 2017-01-05 18:52:22 UTC
Taking this review.

Comment 2 Neal Gompa 2017-01-05 18:54:42 UTC
Initial issue detected:

> - Package does not contain any libtool archives (.la)
>  Note: gala : /usr/lib64/gala/plugins/libgala-maskcorners.la gala :
>  /usr/lib64/gala/plugins/libgala-notify.la gala : /usr/lib64/gala/plugins
>  /libgala-zoom.la
>  See: http://fedoraproject.org/wiki/Packaging/Guidelines#StaticLibraries

Please purge all libtool archives from the package.

You can use a snippet like this in the %install phase to do it:

find %{buildroot} -name '*.la' -print -delete

Comment 4 Neal Gompa 2017-01-05 19:25:30 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated


===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Development (unversioned) .so files in -devel subpackage, if present.
     Note: Unversioned so-files in private %_libdir subdirectory (see
     attachment). Verify they are not in ld path.
[x]: Header files in -devel subpackage, if present.
[x]: ldconfig called in %post and %postun if required.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "GPL (v3 or later)", "Unknown or generated", "MIT/X11 (BSD
     like)", "FSF Unlimited GPL", "FSF All Permissive", "FSF Unlimited".
     142 files have unknown license. Detailed output of licensecheck in
     /home/makerpm/1410524-gala/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package requires other packages for directories it uses.
     Note: No known owner of /usr/share/locale/ckb/LC_MESSAGES,
     /usr/share/locale/ckb
[x]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr/share/locale/ckb,
     /usr/share/vala, /usr/share/vala/vapi,
     /usr/share/locale/ckb/LC_MESSAGES
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: The spec file handles locales properly.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[x]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: gtk-update-icon-cache is invoked in %postun and %posttrans if package
     contains icons.
     Note: icons in gala
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 20480 bytes in 2 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package contains desktop file if it is a GUI application.
[x]: Package installs a %{name}.desktop using desktop-file-install or
     desktop-file-validate if there is such a file.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in gala-
     libs , gala-devel , gala-debuginfo
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Scriptlets must be sane, if used.
[x]: SourceX tarball generation or download is documented.
     Note: Package contains tarball without URL, check comments
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Package should not use obsolete m4 macros
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: gala-0.3.0-0.bzr552.2.fc26.x86_64.rpm
          gala-libs-0.3.0-0.bzr552.2.fc26.x86_64.rpm
          gala-devel-0.3.0-0.bzr552.2.fc26.x86_64.rpm
          gala-debuginfo-0.3.0-0.bzr552.2.fc26.x86_64.rpm
          gala-0.3.0-0.bzr552.2.fc26.src.rpm
gala.x86_64: W: name-repeated-in-summary C Gala
gala.x86_64: W: no-manual-page-for-binary gala
gala.x86_64: W: desktopfile-without-binary /usr/share/applications/gala-multitaskingview.desktop dbus-send
gala-devel.x86_64: W: only-non-binary-in-usr-lib
gala-devel.x86_64: W: no-documentation
gala.src: W: name-repeated-in-summary C Gala
gala.src: W: strange-permission make-tarball.sh 775
gala.src: W: invalid-url Source0: gala-0.3.0.552.tar.xz
5 packages and 0 specfiles checked; 0 errors, 8 warnings.




Rpmlint (debuginfo)
-------------------
Checking: gala-debuginfo-0.3.0-0.bzr552.2.fc26.x86_64.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.





Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory
gala-devel.x86_64: W: only-non-binary-in-usr-lib
gala-devel.x86_64: W: no-documentation
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libgranite.so.3
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libgnome-desktop-3.so.12
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libgee-0.8.so.2
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libpangoft2-1.0.so.0
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libfontconfig.so.1
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libfreetype.so.6
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libudev.so.1
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libinput.so.10
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libxkbcommon.so.0
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libgthread-2.0.so.0
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /usr/lib64/mutter/libmutter-cogl-pango.so
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /usr/lib64/mutter/libmutter-cogl-path.so
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libcairo-gobject.so.2
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libatk-1.0.so.0
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libpangocairo-1.0.so.0
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libpango-1.0.so.0
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libjson-glib-1.0.so.0
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libwayland-egl.so.1
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libwayland-client.so.0
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libXtst.so.6
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libXi.so.6
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /usr/lib64/mutter/libmutter-cogl.so
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libm.so.6
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libgmodule-2.0.so.0
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libgbm.so.1
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libdrm.so.2
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libwayland-server.so.0
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libEGL.so.1
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libXext.so.6
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libXdamage.so.1
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libXfixes.so.3
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libXcomposite.so.1
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libXrandr.so.2
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libX11.so.6
gala-libs.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgala.so.0.0.0 /lib64/libpthread.so.0
gala.x86_64: W: name-repeated-in-summary C Gala
gala.x86_64: W: no-manual-page-for-binary gala
4 packages and 0 specfiles checked; 0 errors, 39 warnings.



Requires
--------
gala-debuginfo (rpmlib, GLIBC filtered):

gala-devel (rpmlib, GLIBC filtered):
    /usr/bin/pkg-config
    gala-libs(x86-64)
    libgala.so.0()(64bit)
    pkgconfig(gdk-pixbuf-2.0)
    pkgconfig(glib-2.0)
    pkgconfig(gobject-2.0)
    pkgconfig(libmutter)
    pkgconfig(mutter-clutter-1.0)
    pkgconfig(mutter-cogl-1.0)
    pkgconfig(mutter-cogl-pango-1.0)
    pkgconfig(mutter-cogl-path-1.0)

gala-libs (rpmlib, GLIBC filtered):
    /sbin/ldconfig
    libEGL.so.1()(64bit)
    libX11.so.6()(64bit)
    libXcomposite.so.1()(64bit)
    libXdamage.so.1()(64bit)
    libXext.so.6()(64bit)
    libXfixes.so.3()(64bit)
    libXi.so.6()(64bit)
    libXrandr.so.2()(64bit)
    libXtst.so.6()(64bit)
    libatk-1.0.so.0()(64bit)
    libbamf3.so.2()(64bit)
    libc.so.6()(64bit)
    libcairo-gobject.so.2()(64bit)
    libcairo.so.2()(64bit)
    libdrm.so.2()(64bit)
    libfontconfig.so.1()(64bit)
    libfreetype.so.6()(64bit)
    libgbm.so.1()(64bit)
    libgdk-3.so.0()(64bit)
    libgdk_pixbuf-2.0.so.0()(64bit)
    libgee-0.8.so.2()(64bit)
    libgio-2.0.so.0()(64bit)
    libglib-2.0.so.0()(64bit)
    libgmodule-2.0.so.0()(64bit)
    libgnome-desktop-3.so.12()(64bit)
    libgobject-2.0.so.0()(64bit)
    libgranite.so.3()(64bit)
    libgthread-2.0.so.0()(64bit)
    libgtk-3.so.0()(64bit)
    libinput.so.10()(64bit)
    libjson-glib-1.0.so.0()(64bit)
    libm.so.6()(64bit)
    libmutter-clutter-1.0.so()(64bit)
    libmutter-cogl-pango.so()(64bit)
    libmutter-cogl-path.so()(64bit)
    libmutter-cogl.so()(64bit)
    libmutter.so.0()(64bit)
    libpango-1.0.so.0()(64bit)
    libpangocairo-1.0.so.0()(64bit)
    libpangoft2-1.0.so.0()(64bit)
    libplank.so.1()(64bit)
    libpthread.so.0()(64bit)
    libudev.so.1()(64bit)
    libwayland-client.so.0()(64bit)
    libwayland-egl.so.1()(64bit)
    libwayland-server.so.0()(64bit)
    libxkbcommon.so.0()(64bit)
    rtld(GNU_HASH)

gala (rpmlib, GLIBC filtered):
    /bin/sh
    dbus
    gala-libs(x86-64)
    hicolor-icon-theme
    libEGL.so.1()(64bit)
    libX11.so.6()(64bit)
    libXcomposite.so.1()(64bit)
    libXdamage.so.1()(64bit)
    libXext.so.6()(64bit)
    libXfixes.so.3()(64bit)
    libXi.so.6()(64bit)
    libXrandr.so.2()(64bit)
    libXtst.so.6()(64bit)
    libatk-1.0.so.0()(64bit)
    libbamf3.so.2()(64bit)
    libc.so.6()(64bit)
    libcairo-gobject.so.2()(64bit)
    libcairo.so.2()(64bit)
    libdrm.so.2()(64bit)
    libfontconfig.so.1()(64bit)
    libfreetype.so.6()(64bit)
    libgala.so.0()(64bit)
    libgbm.so.1()(64bit)
    libgdk-3.so.0()(64bit)
    libgdk_pixbuf-2.0.so.0()(64bit)
    libgee-0.8.so.2()(64bit)
    libgio-2.0.so.0()(64bit)
    libglib-2.0.so.0()(64bit)
    libgmodule-2.0.so.0()(64bit)
    libgnome-desktop-3.so.12()(64bit)
    libgobject-2.0.so.0()(64bit)
    libgranite.so.3()(64bit)
    libgthread-2.0.so.0()(64bit)
    libgtk-3.so.0()(64bit)
    libinput.so.10()(64bit)
    libjson-glib-1.0.so.0()(64bit)
    libm.so.6()(64bit)
    libmutter-clutter-1.0.so()(64bit)
    libmutter-cogl-pango.so()(64bit)
    libmutter-cogl-path.so()(64bit)
    libmutter-cogl.so()(64bit)
    libmutter.so.0()(64bit)
    libpango-1.0.so.0()(64bit)
    libpangocairo-1.0.so.0()(64bit)
    libpangoft2-1.0.so.0()(64bit)
    libplank.so.1()(64bit)
    libpthread.so.0()(64bit)
    libudev.so.1()(64bit)
    libwayland-client.so.0()(64bit)
    libwayland-egl.so.1()(64bit)
    libwayland-server.so.0()(64bit)
    libxkbcommon.so.0()(64bit)
    rtld(GNU_HASH)



Provides
--------
gala-debuginfo:
    gala-debuginfo
    gala-debuginfo(x86-64)

gala-devel:
    gala-devel
    gala-devel(x86-64)
    pkgconfig(gala)

gala-libs:
    gala-libs
    gala-libs(x86-64)
    libgala.so.0()(64bit)

gala:
    application()
    application(gala-multitaskingview.desktop)
    application(gala-wayland.desktop)
    application(gala.desktop)
    gala
    gala(x86-64)
    libgala-maskcorners.so()(64bit)
    libgala-notify.so()(64bit)
    libgala-zoom.so()(64bit)



Unversioned so-files
--------------------
gala: /usr/lib64/gala/plugins/libgala-maskcorners.so
gala: /usr/lib64/gala/plugins/libgala-notify.so
gala: /usr/lib64/gala/plugins/libgala-zoom.so

Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/bin/fedora-review -b 1410524 -m fedora-rawhide-x86_64
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, Shell-api, C/C++
Disabled plugins: Java, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Comment 5 Neal Gompa 2017-01-05 19:27:32 UTC
The large number of unused linked libraries is a bit concerning, and upstream needs to fix it.

However, other than that, this package looks good.

PACKAGE APPROVED.

Comment 6 Fabio Valentini 2017-01-05 22:07:56 UTC
I reported the large number of unneeded, directly linked dependencies as a bug upstream:

https://bugs.launchpad.net/gala/+bug/1654405

Comment 7 Gwyn Ciesla 2017-01-05 22:44:25 UTC
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/gala

Comment 8 Fedora Update System 2017-01-06 10:22:26 UTC
gala-0.3.0-0.bzr552.2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-014bc74aea

Comment 9 Fedora Update System 2017-01-06 23:21:02 UTC
gala-0.3.0-0.bzr552.2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-014bc74aea

Comment 10 Fedora Update System 2017-01-07 21:50:09 UTC
gala-0.3.0-0.bzr552.2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.