This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 141053 - "getgrnam failed" complaints in a startup
"getgrnam failed" complaints in a startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-28 15:01 EST by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 13:26:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to initialize revert_group (602 bytes, patch)
2005-12-19 16:36 EST, Jay Fenlason
no flags Details | Diff

  None (edit)
Description Michal Jaegermann 2004-11-28 15:01:13 EST
Description of problem:

While booting, at least on x86_64 machine, I see the following:
....
Remounting root filesystem in read-write mode:             [  OK  ]
Enabling local filesystem quotas:                          [  OK  ]
getgrnam failed for Enabling swap space:                   [  OK  ]
     ^^^^^^^                                                  ^^
INIT: Entering runlevel: 3
....

'getrnmame'???  That looks like for quotas, not in use here,
and "Enabling swap space" is really the next line.  Hm ...

Version-Release number of selected component (if applicable):
initscripts-7.99-1

How reproducible:
100%
Comment 1 Bill Nottingham 2004-11-28 15:48:29 EST
a) are you using quotas
b) do you have groups defined for pam_console use that don't exist?
Comment 2 Michal Jaegermann 2004-11-28 18:19:08 EST
> a) are you using quotas
As I wrote "looks like for quotas, not in use here".
That is why I got somewhat baffled by this message.

> b) do you have groups defined for pam_console use that don't exist?
That would be it.  It turns out that when trying to get some
reasonable behaviour from a scanner I accidentally added one character
on some line, which is as a matter of fact not used at all, in 
/etc/security/console.perms.  Without your question I could be
looking for a long time. :-)
Comment 3 Jay Fenlason 2005-12-19 16:19:33 EST
This is an actual bug in pam.  If revert_user is NULL, revert_group is never 
initialized, and points to garbage. 
Comment 4 Jay Fenlason 2005-12-19 16:36:08 EST
Created attachment 122424 [details]
Patch to initialize revert_group

Note You need to log in before you can comment on or make changes to this bug.