Bug 1410533 - silently ignore incorrect keywords in config.json
Summary: silently ignore incorrect keywords in config.json
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: runc
Version: 7.3
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Lokesh Mandvekar
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 16:30 UTC by Qian Cai
Modified: 2017-02-01 22:27 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 22:27:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Qian Cai 2017-01-05 16:30:42 UTC
Description of problem:
runc silently ignore incorrect keywords in config.json before it runs. For example,


"linux": {
    "rootPropagation": "shared"
...

instead of "rootfsPropagation". This is going to suffer the user-experience.

Version-Release number of selected component (if applicable):
runc-0.1.1-5.el7.x86_64

How reproducible:
always

Comment 2 Qian Cai 2017-02-01 22:26:52 UTC
Open an issue upstream in oci-runtime-tools,
https://github.com/opencontainers/runtime-tools/issues/317

and close this one out since not an issue with runc.


Note You need to log in before you can comment on or make changes to this bug.