Bug 1410560 - gnome-session is not started by vnc-server when the server is run as systemd service
Summary: gnome-session is not started by vnc-server when the server is run as systemd ...
Keywords:
Status: CLOSED DUPLICATE of bug 896648
Alias: None
Product: Fedora
Classification: Fedora
Component: tigervnc
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Grulich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 18:31 UTC by Jan Stavel
Modified: 2017-01-06 08:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-06 08:33:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan Stavel 2017-01-05 18:31:53 UTC
Description of problem:


Version-Release number of selected component (if applicable):

Fedora 25

    Given a system is Fedora 25 with GNOME group installed 
      and a user prepared for running vncserver on display :2
    following https://docs.fedoraproject.org/en-US/Fedora/25/html/System_Administrators_Guide/ch-TigerVNC.html

    If I run vncserver by hand as the user
      and I connect to the box by vncviewer
    Then I see gnome desktop.

    If I run vncserver as systemd service
      and I connect to the box by vncviewer
    Then I see a black screen
     and I have to run gnome-session by hand.

Actual results:

    no gnome session appears

Expected results:

    gnome session should be run


Additional info:

  The box with this problem is ready for you. Ping me if you want to login.
  
  rhsm-yourkit-monitoring.usersys.redhat.com

Comment 1 Jan Grulich 2017-01-06 08:33:28 UTC

*** This bug has been marked as a duplicate of bug 896648 ***


Note You need to log in before you can comment on or make changes to this bug.