Bug 1410569 - nss-pem can't load ECDSA private keys
Summary: nss-pem can't load ECDSA private keys
Keywords:
Status: CLOSED DUPLICATE of bug 1369251
Alias: None
Product: Fedora
Classification: Fedora
Component: nss-pem
Version: 25
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 18:47 UTC by Hristo Venev
Modified: 2017-01-05 20:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-05 20:50:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Hristo Venev 2017-01-05 18:47:39 UTC
It can only load pretend to load PKCS8 keys (the traditional OpenSSL format fails). Then it treats the keys as RSA keys and fails to do anything. SSL operations then return SEC_ERROR_INVALID_KEY.

Comment 1 Kamil Dudka 2017-01-05 20:50:17 UTC
Thank you for reporting the bug!  This is already tracked as bug #1369251.

*** This bug has been marked as a duplicate of bug 1369251 ***


Note You need to log in before you can comment on or make changes to this bug.