Bug 1410611 - The ironic service has different region name than others
Summary: The ironic service has different region name than others
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: z3
: 10.0 (Newton)
Assignee: Emilien Macchi
QA Contact: Alex Schultz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 22:03 UTC by Ken Holden
Modified: 2017-06-28 14:44 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.2.0-17.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-28 14:44:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1661839 None None None 2017-02-04 13:53:06 UTC
OpenStack gerrit 439835 None None None 2017-03-01 20:36:45 UTC
Red Hat Product Errata RHBA-2017:1585 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 director Bug Fix Advisory 2017-06-28 18:42:51 UTC

Description Ken Holden 2017-01-05 22:03:05 UTC
Description of problem:
OSP10 director set the ironic endpoint to "RegionOne" instead of "regionOne". This caused the UI to display two regions with different services.  If you select the wrong region, you can not browse to admin or project tabs as you are forced back to the login prompt. You need to select the correct region before you can browse away from the Identity tab.

$ openstack endpoint list
+----------------------------------+-----------+--------------+-----------------+
| ID                               | Region    | Service Name | Service Type    |
+----------------------------------+-----------+--------------+-----------------+
| ba999a19862a4924bd2c6156cc6147e2 | regionOne | aodh         | alarming        |
| 13a6753845ec4a348df525241a33a7f7 | regionOne | cinderv3     | volumev3        |
| b04fe6d85c194b1fa1a77996694103e5 | regionOne | cinderv2     | volumev2        |
| 7f0e6f9c54d249d2a036c357398b8b8c | regionOne | neutron      | network         |
| 836ce72e16fd4e07a0f39a0d98a2c30a | regionOne | keystone     | identity        |
| 5304258442024e3cb5b8870132f35a1f | regionOne | heat         | orchestration   |
| cf1e7243d58043a8b1c1b1ad75733d83 | regionOne | cinder       | volume          |
| 73f0e2f9d0374a1990379a0aa2d62552 | RegionOne | ironic       | baremetal       |
| b2e1578963fb41bb99898505604ca32f | regionOne | heat-cfn     | cloudformation  |
| bcd843301818480fbf3b5d846d618286 | regionOne | glance       | image           |
| 9e77675a0053446194cd089df4458f4e | regionOne | swift        | object-store    |
| ac02b55ff4ec417cbc027016abbf8e09 | regionOne | sahara       | data-processing |
| 3cc178fece0c47eebcdee49826bee4fe | regionOne | ceilometer   | metering        |
| babf436f8e974d9ab276f5307b928b40 | regionOne | nova         | compute         |
| 5592e3ebd1f2454b969a4b49814db789 | regionOne | gnocchi      | metric          |
+----------------------------------+-----------+--------------+-----------------+


Version-Release number of selected component (if applicable):
OSP 10

Steps to Reproduce:
1. Deploy OSP10 Overcloud with OSP 10 Director sourcing /usr/share/openstack-tripleo-heat-templates/environments/services/ironic.yaml template
2. source overcloudrc and run 'openstack endpoint list'


Actual results:
openstack endpoint list shows the following for ironic:
| 73f0e2f9d0374a1990379a0aa2d62552 | RegionOne | ironic       | baremetal       |


Expected results:
openstack endpoint list should show the following:
| 73f0e2f9d0374a1990379a0aa2d62552 | regionOne | ironic       | baremetal       |


Additional info:
heat templates installed:  openstack-tripleo-heat-templates-5.1.0-7.el7ost.noarch

Comment 3 Alex Schultz 2017-03-21 20:51:42 UTC
Confirmed region now lists correctly with openstack-tripleo-heat-templates-5.2.0-6.el7ost.noarch

Comment 6 errata-xmlrpc 2017-06-28 14:44:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1585


Note You need to log in before you can comment on or make changes to this bug.