Bug 1410702 - Disk stuck in 'locked' state after cloning finished.
Summary: Disk stuck in 'locked' state after cloning finished.
Keywords:
Status: CLOSED DUPLICATE of bug 1395793
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.0.5.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.0.6
: ---
Assignee: Tal Nisan
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 06:24 UTC by hifxj
Modified: 2017-01-09 10:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-09 09:57:34 UTC
oVirt Team: Storage
tnisan: ovirt-4.0.z?


Attachments (Terms of Use)
Screenshot. (119.80 KB, image/png)
2017-01-06 06:24 UTC, hifxj
no flags Details
engine.log (3.96 KB, application/x-gzip)
2017-01-09 07:55 UTC, hifxj
no flags Details
vdsm.log (91.67 KB, application/x-gzip)
2017-01-09 07:55 UTC, hifxj
no flags Details

Description hifxj 2017-01-06 06:24:19 UTC
Created attachment 1237868 [details]
Screenshot.

Description of problem:

When 'Clone VM' finished, the vm(both source and destination) disk always in 'locked' state.
Have to use 'unlock_entity.sh' to manually unlock it.

Version-Release number of selected component (if applicable):


How reproducible:

100%.

Steps to Reproduce:
1. Create a new vm(v1) from a template.
2. Select v1
3. Click 'Clone VM', input 'v1-cloned'.
4. Wait for cloning task finish.

Actual results:
'v1' and 'v1-cloned' disk stuck in 'locked' state.

Expected results:
Disk should be in 'Active' state.

Additional info:

The storage domain is glusterfs. I've not tried other types(NFS) yet.

Comment 1 Tomas Jelinek 2017-01-06 08:04:37 UTC
Please attach the engine logs and the logs from the spm vdsm.

Comment 2 hifxj 2017-01-09 07:55:03 UTC
Created attachment 1238579 [details]
engine.log

Comment 3 hifxj 2017-01-09 07:55:29 UTC
Created attachment 1238580 [details]
vdsm.log

Comment 4 hifxj 2017-01-09 07:56:35 UTC
Attached engine.log/vdsm.log.
If you need other info, let me know. 
Thanks.

Comment 5 Tal Nisan 2017-01-09 09:57:34 UTC

*** This bug has been marked as a duplicate of bug 1395793 ***

Comment 6 hifxj 2017-01-09 10:07:22 UTC
My bug searching skill is not that well, though ;)


Note You need to log in before you can comment on or make changes to this bug.