Bug 1410707 - [geo-rep]: Config commands fail when the status is 'Created'
Summary: [geo-rep]: Config commands fail when the status is 'Created'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On: 1404678
Blocks: 1410699
TreeView+ depends on / blocked
 
Reported: 2017-01-06 06:49 UTC by Kotresh HR
Modified: 2017-03-08 10:24 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.9.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1404678
Environment:
Last Closed: 2017-03-08 09:33:49 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2017-01-06 06:49:18 UTC
+++ This bug was initially created as a clone of Bug #1404678 +++

Description of problem:
Geo-replication config commands fail when geo-rep status is in 'Created'.
It fails with missing pid-file entry from the config file.

Version-Release number of selected component (if applicable):
master

How reproducible:
Always

Steps to Reproduce:
1. Create master volume and slave volume
2. Establish geo-rep between them. Do not start.
3. gluster vol geo-rep <mastervol> <slavehost>::<slavevol> config use_meta_volume true


Actual results:
The config command fails

Expected results:
The config command should not fail.

Comment 1 Worker Ant 2017-01-06 08:04:43 UTC
REVIEW: http://review.gluster.org/16346 (glusterd/geo-rep: Fix geo-rep config issue) posted (#1) for review on release-3.9 by Kotresh HR (khiremat@redhat.com)

Comment 2 Worker Ant 2017-01-11 04:53:56 UTC
COMMIT: http://review.gluster.org/16346 committed in release-3.9 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 499efceee3b7899ba0bc833f386a303ec263211a
Author: Kotresh HR <khiremat@redhat.com>
Date:   Wed Dec 14 07:03:28 2016 -0500

    glusterd/geo-rep: Fix geo-rep config issue
    
    Problem:
    Geo-replication config commands fail when geo-rep
    status is in 'Created'.
    
    Cause:
    During staging phase of geo-rep config, it checks
    for the existence of 'monitor.pid' file. But the
    pid file gets created only on start of geo-rep.
    Hence it fails.
    
    Fix:
    Do not check for the existence of pid-file during
    staging for config commands. It is not required.
    
    > Change-Id: I626d368b249cf0423c7f49b4284465508371f566
    > BUG: 1404678
    > Signed-off-by: Kotresh HR <khiremat@redhat.com>
    > Reviewed-on: http://review.gluster.org/16132
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Aravinda VK <avishwan@redhat.com>
    > Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: I626d368b249cf0423c7f49b4284465508371f566
    BUG: 1410707
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/16346
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 3 Kaushal 2017-03-08 10:24:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.1, please open a new bug report.

glusterfs-3.9.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-January/029725.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.