Bug 1410708 - glusterd/geo-rep: geo-rep config command leaks fd
Summary: glusterd/geo-rep: geo-rep config command leaks fd
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1410711
TreeView+ depends on / blocked
 
Reported: 2017-01-06 07:16 UTC by Kotresh HR
Modified: 2017-01-16 12:28 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1410711 (view as bug list)
Environment:
Last Closed: 2017-01-16 12:28:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2017-01-06 07:16:55 UTC
Description of problem:
If geo-rep config is set when it is running, it will leak fd.

Version-Release number of selected component (if applicable):
3.8

How reproducible:
always

Steps to Reproduce:
1. Create gluster volumes and establish geo-rep session
2. Start geo-rep
3. Set any geo-rep config

Actual results:
fd should not be leaked

Expected results:
fd leaks

Additional info:
In master branch, the issue is fixed as part collection of patches went into
https://bugzilla.redhat.com/show_bug.cgi?id=1369124

Only backporting of the patch http://review.gluster.org/#/c/15263/ is required.

Comment 1 Worker Ant 2017-01-06 07:40:32 UTC
REVIEW: http://review.gluster.org/16344 (glusterd (geo-rep): fix unused variable warnings/errors) posted (#1) for review on release-3.8 by Kotresh HR (khiremat@redhat.com)

Comment 2 Worker Ant 2017-01-08 10:59:25 UTC
COMMIT: http://review.gluster.org/16344 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 303ae314787ee2d5e5f2fadf8576b87f9c0fb0bf
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Mon Aug 22 13:22:02 2016 -0400

    glusterd (geo-rep): fix unused variable warnings/errors
    
    This patch fixes the fd leak when geo-rep config
    command is run while geo-rep is running.
    
    NOTE:
    The patch is backport of http://review.gluster.org/15263
    which was one of the collection of patches to fix the
    bug https://bugzilla.redhat.com/show_bug.cgi?id=1369124
    
    > Change-Id: I2edacd3d0f3924b1be0f0398ba9ac076459c5a61
    > BUG: 1369124
    > Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    > Reviewed-on: http://review.gluster.org/15263
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    
    Change-Id: I2edacd3d0f3924b1be0f0398ba9ac076459c5a61
    BUG: 1410708
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/16344
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Niels de Vos 2017-01-16 12:28:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.8, please open a new bug report.

glusterfs-3.8.8 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2017-January/000064.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.