Bug 1410724 - Need to include gnome-session 3.16 in RHEL 7 or enable the --disable-acceleration-check feature in gnome-session 3.14
Summary: Need to include gnome-session 3.16 in RHEL 7 or enable the --disable-accelera...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-session
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1420851
TreeView+ depends on / blocked
 
Reported: 2017-01-06 09:07 UTC by Jos Collin
Modified: 2020-03-11 15:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-16 14:05:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jos Collin 2017-01-06 09:07:29 UTC
Description of problem:
Since the introduction of Gnome 3.x the customer faces a severe Problem with a Military Grade visualisation Software called GoGlobalUX. This software needs "gnome-session --disable-acceleration-check" feature enabled to work with Gnome. This Parameter has been introduced in version 3.16 already. So the customer want either gnome-session 3.16 to be a part of RHEL7 or enable the --disable-acceleration-check feature in gnome-session 3.14.

Version-Release number of selected component (if applicable):
3.14

How reproducible:
Not Applicable. There is no specific steps given by the customer to reproduce the actual issue.

Steps to Reproduce:
Not Applicable.

Actual results:
The customer faces a severe Problem with a Military Grade visualisation Software called GoGlobalUX due to gnome-session 3.14.

Expected results:
Needs gnome-session 3.16 to be integrated with RHEL 7 or enable the --disable-acceleration-check feature in gnome-session 3.14.

Additional info:

Comment 3 Paul Raines 2017-03-16 14:57:45 UTC
Support for --disable-acceleration-check would be a solution for those who want to use GNOME on a RHEL7 box over X2Go, VNC, NX, etc.

https://bugzilla.redhat.com/show_bug.cgi?id=896648

Comment 4 Ray Strode [halfline] 2017-03-16 15:43:33 UTC
But disabling the acceleration check won't make it work automatically on platforms that don't support OpenGL.  It just disables the check, the code still requires the features.


Note You need to log in before you can comment on or make changes to this bug.