Bug 1410727 - Need not list Secret in Other Resources because of secrets page
Summary: Need not list Secret in Other Resources because of secrets page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 09:13 UTC by Xingxing Xia
Modified: 2017-07-24 14:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
We have already fixed this in 3.5, it was expected behavior in 3.4 because we only had partial support for Secrets.
Clone Of:
Environment:
Last Closed: 2017-04-12 19:08:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0884 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description Xingxing Xia 2017-01-06 09:13:55 UTC
Description of problem:
Need not list Secret in Other Resources because of secrets page

Version-Release number of selected component (if applicable):
openshift v3.4.0.38

How reproducible:
Always

Steps to Reproduce:
1. Create project
2. On web console, click Resources --> Other Resources, check resource list
3. On web console, click Resources --> Secrets

Actual results:
2. Secret is in the list
3. Secrets page only shows 3 secrets, but clicking Secret from step 2's list, it shows all 9 secrets

Expected results:
2. Need not list Secret now because of secrets page
3. Secrets page should also show all secrets

Additional info:

Comment 1 Jessica Forrester 2017-01-09 14:23:30 UTC
We have already fixed this in 3.5, it was expected behavior in 3.4 because we only had partial support for Secrets.

Comment 2 Troy Dawson 2017-01-20 23:32:20 UTC
This has been merged into ocp and is in OCP v3.5.0.7 or newer.

Comment 3 Xingxing Xia 2017-01-22 03:13:15 UTC
Thanks. Verified in OCP v3.5.0.7. Now Secrets page also shows all secrets. "Other Resources" drop-down list does not have Secret any longer

Comment 5 errata-xmlrpc 2017-04-12 19:08:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.