Bug 1410754 - ISE500 during creating new kickstart by uploading file.
Summary: ISE500 during creating new kickstart by uploading file.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gennadii Altukhov
QA Contact: Pavel Studeník
URL:
Whiteboard:
Depends On:
Blocks: sat580-low
TreeView+ depends on / blocked
 
Reported: 2017-01-06 11:18 UTC by Pavel Studeník
Modified: 2017-06-21 12:07 UTC (History)
2 users (show)

Fixed In Version: spacewalk-java-2.5.14-41-sat
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-21 12:07:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pavel Studeník 2017-01-06 11:18:52 UTC
Description of problem:
I received ISE500 when I tried to choose "Virtualization Type" on page /rhn/kickstart/AdvancedModeCreate.do

spacewalk-java-2.5.14-36.el6sat.noarch

2017-01-03 14:36:59,794 [TP-Processor2] WARN  org.apache.struts.action.RequestProcessor - Unhandled Exception thrown: class java.lang.NullPointerException
2017-01-03 14:36:59,794 [TP-Processor2] ERROR com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction. Rolling back
javax.servlet.ServletException: java.lang.NullPointerException
        at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:520)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:427)
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:228)
        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:105)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1913)
        at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:462)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:643)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:723)
...
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:299)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:769)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:698)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:891)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
        at java.lang.Thread.run(Thread.java:785)
Caused by:
java.lang.NullPointerException
        at com.redhat.rhn.domain.kickstart.builder.KickstartParser.<init>(KickstartParser.java:46)
        at com.redhat.rhn.frontend.action.kickstart.AdvancedModeDetailsAction.submit(AdvancedModeDetailsAction.java:180)
        at com.redhat.rhn.frontend.action.kickstart.AdvancedModeDetailsAction.execute(AdvancedModeDetailsAction.java:111)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:425)

How reproducible:
always

Steps to Reproduce:
1. go to /rhn/kickstart/AdvancedModeCreate.do
2. fill kickstart tree and label
3. field Virtualization Type causes ISE 500


Additional info:
I can reproduce it, it also occurs if you do not provide Kickstart File and press button create.

Comment 1 Gennadii Altukhov 2017-01-06 13:21:09 UTC
Patch is available in upstream. spacewalk.git:
4c5ff6027c516ab2b5e5fe0436142f6c4ddd60d9

Comment 4 Pavel Studeník 2017-01-11 12:48:12 UTC
verified with spacewalk-java-2.5.14-42.el6sat.noarch


Note You need to log in before you can comment on or make changes to this bug.