Bug 1410778 - [RFE] Integrate Vitrage Root Cause Analysis (RCA) engine into RHOSP
Summary: [RFE] Integrate Vitrage Root Cause Analysis (RCA) engine into RHOSP
Keywords:
Status: CLOSED DUPLICATE of bug 1406499
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: distribution
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Lon Hohberger
QA Contact: Udi Shkalim
URL: https://launchpad.net/vitrage
Whiteboard:
Depends On: 1342987 1390608
Blocks: 1419948 1403737 1406499
TreeView+ depends on / blocked
 
Reported: 2017-01-06 13:10 UTC by Bertrand
Modified: 2018-01-28 08:09 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-31 20:11:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Bertrand 2017-01-06 13:10:20 UTC
Scope / Description:
Vitrage is an OpenStack project which aims at organizing, analyzing and expanding OpenStack alarms & events, yielding insights regarding the root cause of problems and deducing their existence before they are directly detected. By doing so, it promotes clarity and transparency of the cloud structure and state. 

Nokia would like Vitrage to be integrated (packaged, deployed) as part of RHOSP.

More information about Vitrage can be found on the wiki page[1] as well as in launchpad[2] and on github[3]. A set of summit presentation are also available[4], [5], [6]

[1] https://wiki.openstack.org/wiki/Vitrage
[2] https://launchpad.net/vitrage
[3] https://github.com/openstack/vitrage
[4] https://www.openstack.org/videos/video/demo-openstack-and-opnfv-keeping-your-mobile-phone-calls-connected
[5] https://www.openstack.org/videos/video/nokia-root-cause-analysis-principles-and-practice-in-openstack-and-beyond 
[6] https://www.openstack.org/videos/video/fault-management-with-openstack-congress-and-vitrage-based-on-opnfv-doctor-framework


Additional Info:
Partner: Nokia
Contact name: Elisha Rosensweig
Contact email: elisha.rosensweig@nokia.com
Contact name: Ifat Afek (PTL)
Contact email: ifat.afek@nokia.com
Contact name: Eyal Bar-Ilan, 
Contact email: eyalb1@gmail.com, Eyal.Bar-Ilan@nokia.com

Red Hat EPM: Bertrand Rault
Contact Email: Brault@redhat.com

Comment 4 Maria Bracho 2017-02-21 21:31:48 UTC
After review, we've decided not to include Vitrage in our 12 (Pike) cycle.

Comment 5 Anandeep Pannu 2017-10-31 20:11:10 UTC

*** This bug has been marked as a duplicate of bug 1406499 ***


Note You need to log in before you can comment on or make changes to this bug.