Bug 1410799 - RFE: add ks_meta option to disable beah/beaker output to console.log
Summary: RFE: add ks_meta option to disable beah/beaker output to console.log
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: general
Version: develop
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: 25.0
Assignee: Dan Callaghan
QA Contact: Anwesha Chatterjee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 14:26 UTC by Jiri Kastner
Modified: 2018-03-19 04:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-19 04:18:53 UTC


Attachments (Terms of Use)

Description Jiri Kastner 2017-01-06 14:26:10 UTC
Description of problem:
for realtime kernel we need investigate console.log, which contains kernel traces. reviewing console.log manually is annoying task and automated filtering is complicated because it is mixed with beah and beaker 'spam'.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. run beaker job
2. check console.log


Actual results:
lot of beah and beaker spam

Expected results:
clean console.log with kernel console output

Additional info:

Comment 1 Jiri Kastner 2017-01-06 14:47:52 UTC
maybe only some simply formatted line stating start and end of beaker test and its test phases:

>>>>>>> /distribution/pkginstall - start <<<<<<<<<<<<<
>>>>>>> /distribution/pkginstall/YumInstallPackage_rt-setup - start <<<<<<<<<<<<<
>>>>>>> /distribution/pkginstall/YumInstallPackage_rt-setup -  end  <<<<<<<<<<<<<
>>>>>>> /distribution/pkginstall/pkginstall  - start <<<<<<<<<<<<<
>>>>>>> /distribution/pkginstall/pkginstall  -  end  <<<<<<<<<<<<<
>>>>>>> rhts_task/exit - start <<<<<<<<<<<<<
>>>>>>> rhts_task/exit -  end  <<<<<<<<<<<<<
>>>>>>> /distribution/pkginstall -  end  <<<<<<<<<<<<<

Comment 2 Roman Joost 2017-01-10 00:25:35 UTC
Dear Jiri,

our team talked about possible solutions for this bug. For one, we could add a ks meta option to suppress some of the spew which would probably also useful for other users.

One possible alternative you could look into is restraint. There might be less harness spew in the logs and it should be easier to browse.

Comment 3 Dan Callaghan 2017-11-03 07:58:04 UTC
https://gerrit.beaker-project.org/5908

Adds a ksmeta "beah_no_console_output" to suppress all beah log messages. Note that you can achieve this yourself with the same systemd drop-ins in a <ks_append/> section.

Comment 4 Dan Callaghan 2017-11-05 23:28:58 UTC
(In reply to Dan Callaghan from comment #3)
> https://gerrit.beaker-project.org/5908

This works nicely on RHEL7+ but note that on RHEL6 and earlier, when rhts-compat is left enabled (it is enabled by default), the rhts-compat service still produces some spew on /dev/console. This is somewhat by design, since rhts-compat's purpose is to run tests with stdin+stdout+stderr connected to /dev/console.

If this is undesirable, I would recommend to turn off rhts-compat. There are many reasons why you should just turn it off anyway.

The rhts-compat console spew looks like this:

Running RHTS-Compatibility Service...  
rhts-compat: Waiting for lock.  
lockfile: Try praying, giving up on "/var/run/beah/rm.lock"  
NOTE: This process runs in foreground.  
Use 'service rhts-compat stop' from another terminal to stop it.  
It will not stop immediately but only after running tasks are processed.  
ls: cannot access /var/run/beah/rhts-compat/launchers: No such file or directory  
ls: cannot access /var/run/beah/rhts-compat/launchers: No such file or directory  
ls: cannot access /var/run/beah/rhts-compat/launchers: No such file or directory  
launcher-148040.sh  
Executing:  unconfined, initgroups, runtest  
-- INFO: selinux enabled: trying to switch context...  
/var/lib/beah/tortilla/wrappers.d/initgroups groups:  []  
/var/lib/beah/tortilla/wrappers.d/initgroups no groups found, defaulting to [0]  
+++ basename /var/lib/beah/tortilla/wrappers.d/runtest  
++ tortilla get-next-wrapper runtest  
+ WRAP_NEXT=  
+ /usr/bin/rhts-test-runner.sh  
logger: /usr/bin/rhts-test-runner.sh rhts-extend lab-devel-02.rhts.eng.bos.redhat.com 148040 3000  
2999  
logger: /usr/bin/rhts-test-runner.sh rhts-test-checkin 127.0.0.1:7088 dell-pe1850-01.rhts.eng.bos.redhat.com 13010 /distribution/install 3000 148040  
11/05/17 18:24:12  JobID:13010 Test:/distribution/install Response:1  
logger: /usr/bin/rhts-test-runner.sh rhts-test-update 127.0.0.1:7088 148040 start  beaker-distribution-install  
11/05/17 18:24:12  testID:148040 start:  
/mnt/tests/distribution/install /mnt/tests/distribution/install  
logger: /usr/bin/rhts-test-runner.sh report_finish start...  
jobsl = [1]+ 2208 Done make run >> /mnt/testarea/TESTOUT.log 2>&1  
status = Done  
no machines specified. exiting  
11/05/17 18:24:23  testID:148040 finish:  
Nothing to restore.  
logger: /usr/bin/rhts-test-runner.sh report_finish stop...  
+ rc=0  
+ '[' -n '' ']'  
+ exit 0

Comment 6 Jiri Kastner 2017-12-08 14:31:07 UTC
tried snippets on rhel7, it works nice

Comment 7 Anwesha Chatterjee 2018-01-10 01:44:07 UTC
Verified that when running a job with ks_meta="beah_no_console_output",
( https://beaker-devel.app.eng.bos.redhat.com/beaker-logs/2018/01/136/13661/20561/console.log )
* only kernel messages appear in the console log
* beah logs do not appear

Comment 8 Dan Callaghan 2018-02-06 00:36:04 UTC
This bug was fixed on the release-24 branch, to appear in Beaker 24.6, but we are not planning any more maintenance releases for the 24.x series. The next release will be Beaker 25.0. Updating the milestone accordingly.

Comment 9 Roman Joost 2018-03-19 04:18:53 UTC
Beaker 25.0 has been released.

Release notes are available upstream: https://beaker-project.org/docs/whats-new/release-25.html


Note You need to log in before you can comment on or make changes to this bug.