Bug 1410801 - Use of help docs causes lucene 5 index errors in console log
Summary: Use of help docs causes lucene 5 index errors in console log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: eclipse
Version: rh-eclipse46
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 2.4
Assignee: Mat Booth
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 14:28 UTC by Jeff MAURY
Modified: 2017-04-26 09:22 UTC (History)
2 users (show)

Fixed In Version: rh-eclipse46-eclipse-webtools-3.8.2-1.2.el7, rh-eclipse46-eclipse-4.6.2-4.3.el7, rh-eclipse46-eclipse-rse-3.7.2-1.1.el7, rh-eclipse46-eclipse-mylyn-3.21.0-1.3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-26 09:22:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Eclipse Project 436896 0 None None None 2017-01-31 15:00:19 UTC
Eclipse Project 444689 0 None None None 2017-01-31 14:59:33 UTC
Red Hat Issue Tracker JBDS-3880 0 Major Closed Space in local help path causing error installing Mylyn plugins 2019-03-29 11:40:05 UTC
Red Hat Product Errata RHEA-2017:1142 0 normal SHIPPED_LIVE rh-eclipse46 bug fix and enhancement update 2017-04-26 13:19:40 UTC

Description Jeff MAURY 2017-01-06 14:28:09 UTC
Description of problem:


Version-Release number of selected component (if applicable): 0.20161128.1631.el7


How reproducible:
Always


Steps to Reproduce:
1. Launch Red Hat Eclipse
2. Help -> About -> ?
3.

Actual results:
As of the latest rpm build (10.2-0.20161117.2130) if you click on the (?) icon in any dialog (eg., Help > About > (?) ) you get a TON of Eclipse Help errors caused by Lucene 5.4.1 trying to read content which I presume was created with Lucene 3.5:

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.565
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.jst.ws.consumption.ui.doc.user_1.0.700.v201610271000 [429]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.610
!MESSAGE Help index declared, but missing for plugin org.eclipse.dstore.doc.isv.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.616
!MESSAGE Help index declared, but missing for plugin org.eclipse.platform.doc.isv.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.638
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.jst.ws.axis2.ui.doc.user_1.0.200.v201610271000 [425]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.638
!MESSAGE Help index declared, but missing for plugin org.eclipse.jdt.doc.user.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.640
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.wst.command.env.doc.user_1.5.400.v201610271000 [455]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.675
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.wst.dtdeditor.doc.user_1.0.700.v201610271000 [487]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.676
!MESSAGE Help index declared, but missing for plugin org.eclipse.jdt.doc.isv.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.678
!MESSAGE Help index declared, but missing for plugin org.eclipse.platform.doc.user.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.680
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.jst.j2ee.doc.user_1.1.400.v201610271000 [392]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.687
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.wst.xmleditor.doc.user_1.0.700.v201610271000 [554]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.697
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.wst.xsdeditor.doc.user_1.0.800.v201610271000 [557]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.707
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.jst.ejb.doc.user_1.1.301.v201610271000 [387]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.715
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.jst.ws.axis.ui.doc.user_1.1.200.v201610271000 [418]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.716
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.wst.wsdl.ui.doc.user_1.0.850.v201610271000 [467]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.725
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.wst.webtools.doc.user_1.0.500.v201610271000 [543]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.733
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.wst.server.ui.doc.user_1.1.600.v201610271000 [658]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.738
!MESSAGE Help index declared, but missing for plugin org.eclipse.pde.doc.user.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.745
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.jst.ws.doc.user_1.0.700.v201610271000 [439]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.747
!MESSAGE Help index declared, but missing for plugin org.eclipse.rse.doc.isv.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.749
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.wst.wsi.ui.doc.user_1.0.750.v201610271000 [471]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.760
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.wst.sse.doc.user_1.1.100.v201610271000 [536]. Please use an index built with Lucene 5 or higher.

!ENTRY org.eclipse.help.base 4 0 2016-11-17 16:56:06.762
!MESSAGE Error trying to consume Lucene index from bundle org.eclipse.jst.server.ui.doc.user_1.0.600.v201610271000 [649]. Please use an index built with Lucene 5 or higher.
java.net.URISyntaxException: Illegal character in path at index 56: localhelp:/org.eclipse.mylyn.wikitext.help.ui/help/Mylyn WikiText User Guide.html?lang=en_CA
	at java.net.URI$Parser.fail(URI.java:2848)
	at java.net.URI$Parser.checkChars(URI.java:3021)
	at java.net.URI$Parser.parseHierarchical(URI.java:3105)
	at java.net.URI$Parser.parse(URI.java:3053)
	at java.net.URI.<init>(URI.java:588)
	at java.net.URL.toURI(URL.java:939)
	at org.eclipse.help.internal.base.util.ProxyUtil.getProxy(ProxyUtil.java:57)
	at org.eclipse.help.internal.base.util.ProxyUtil.getConnection(ProxyUtil.java:108)
	at org.eclipse.help.internal.base.util.ProxyUtil.getStream(ProxyUtil.java:124)
	at org.eclipse.help.internal.search.HTMLSearchParticipant.isXHTML(HTMLSearchParticipant.java:108)
	at org.eclipse.help.internal.search.HTMLSearchParticipant.addDocument(HTMLSearchParticipant.java:47)
	at org.eclipse.help.internal.search.SearchIndex.addDocument(SearchIndex.java:248)
	at org.eclipse.help.internal.search.IndexingOperation.addDocuments(IndexingOperation.java:252)
	at org.eclipse.help.internal.search.IndexingOperation.addNewDocuments(IndexingOperation.java:159)
	at org.eclipse.help.internal.search.IndexingOperation.execute(IndexingOperation.java:106)
	at org.eclipse.help.internal.search.LocalSearchManager.updateIndex(LocalSearchManager.java:630)
	at org.eclipse.help.internal.search.LocalSearchManager.ensureIndexUpdated(LocalSearchManager.java:604)
	at org.eclipse.help.internal.search.federated.IndexerJob.run(IndexerJob.java:32)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
java.net.URISyntaxException: Illegal character in path at index 56: localhelp:/org.eclipse.mylyn.wikitext.help.ui/help/Mylyn WikiText User Guide.html?lang=en_CA
	at java.net.URI$Parser.fail(URI.java:2848)
	at java.net.URI$Parser.checkChars(URI.java:3021)
	at java.net.URI$Parser.parseHierarchical(URI.java:3105)
	at java.net.URI$Parser.parse(URI.java:3053)
	at java.net.URI.<init>(URI.java:588)
	at java.net.URL.toURI(URL.java:939)
	at org.eclipse.help.internal.base.util.ProxyUtil.getProxy(ProxyUtil.java:57)
	at org.eclipse.help.internal.base.util.ProxyUtil.getConnection(ProxyUtil.java:108)
	at org.eclipse.help.internal.base.util.ProxyUtil.getStream(ProxyUtil.java:124)
	at org.eclipse.help.search.SearchParticipantXML.addDocument(SearchParticipantXML.java:308)
	at org.eclipse.help.internal.search.HTMLSearchParticipant.addDocument(HTMLSearchParticipant.java:53)
	at org.eclipse.help.internal.search.SearchIndex.addDocument(SearchIndex.java:248)
	at org.eclipse.help.internal.search.IndexingOperation.addDocuments(IndexingOperation.java:252)
	at org.eclipse.help.internal.search.IndexingOperation.addNewDocuments(IndexingOperation.java:159)
	at org.eclipse.help.internal.search.IndexingOperation.execute(IndexingOperation.java:106)
	at org.eclipse.help.internal.search.LocalSearchManager.updateIndex(LocalSearchManager.java:630)
	at org.eclipse.help.internal.search.LocalSearchManager.ensureIndexUpdated(LocalSearchManager.java:604)
	at org.eclipse.help.internal.search.federated.IndexerJob.run(IndexerJob.java:32)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

!ENTRY org.eclipse.help.base 4 4 2016-11-17 16:56:20.057
!MESSAGE Help documentation could not be indexed completely.
!SUBENTRY 1 org.eclipse.help.base 4 4 2016-11-17 16:56:20.057
!MESSAGE Help document /org.eclipse.platform.doc.isv/reference/api/org/eclipse/ui/ide/undo/package-summary.html cannot be opened.
!SUBENTRY 1 org.eclipse.help.base 4 4 2016-11-17 16:56:20.057
!MESSAGE Help document /org.eclipse.jdt.doc.isv/reference/api/org/eclipse/jdt/debug/ui/launchConfigurations/package-summary.html cannot be opened.
!SUBENTRY 1 org.eclipse.help.base 4 4 2016-11-17 16:56:20.057
!MESSAGE Help document /org.eclipse.platform.doc.isv/reference/api/org/eclipse/ui/activities/package-summary.html cannot be opened.
!SUBENTRY 1 org.eclipse.help.base 4 4 2016-11-17 16:56:20.057
!MESSAGE Help document /org.eclipse.jdt.doc.isv/reference/api/org/eclipse/jdt/core/jdom/package-summary.html cannot be opened.
!SUBENTRY 1 org.eclipse.help.base 4 4 2016-11-17 16:56:20.057
!MESSAGE Help document /org.eclipse.rse.doc.isv/reference/extension-points/org_eclipse_rse_core_systemTypeProviders.html cannot be opened.
!SUBENTRY 1 org.eclipse.help.base 4 4 2016-11-17 16:56:20.057

...



Expected results:


Additional info:

Comment 2 Václav Kadlčík 2017-02-14 07:06:13 UTC
Tested, builds
 * rh-eclipse46-eclipse-webtools-3.8.2-1.2.el7
 * rh-eclipse46-eclipse-4.6.2-4.3.el7
 * rh-eclipse46-eclipse-rse-3.7.2-1.1.el7
 * rh-eclipse46-eclipse-mylyn-3.21.0-1.3.el7
 * rh-eclipse46-eclipse-dltk-5.7.0-1.3.el7 (not present
   in Fixed In Version)
would fix the bug.

Comment 4 Václav Kadlčík 2017-03-07 08:45:05 UTC
Verified in RHSCL 2.4 Beta 1.0, namely:
 * rh-eclipse46-eclipse-webtools-3.8.2-1.4.el7
 * rh-eclipse46-eclipse-4.6.3-1.3.el7
 * rh-eclipse46-eclipse-rse-3.7.2-1.1.el7
 * rh-eclipse46-eclipse-mylyn-3.21.0-1.4.el7
 * rh-eclipse46-eclipse-dltk-5.7.0-1.3.el7

Comment 6 errata-xmlrpc 2017-04-26 09:22:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1142


Note You need to log in before you can comment on or make changes to this bug.