Bug 1410852 - glusterfs-server should depend on firewalld-filesystem
Summary: glusterfs-server should depend on firewalld-filesystem
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: packaging
Version: 3.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On: 1410853
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 15:53 UTC by Niels de Vos
Modified: 2017-02-20 12:33 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8.9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1410853 (view as bug list)
Environment:
Last Closed: 2017-02-20 12:33:40 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2017-01-06 15:53:52 UTC
Description of problem:
Recently RHEL7 was rebased to have firewalld-filesystem available. Because the glusterfs-server RPM installs a .xml file with firewalld rules, this RPM needs to depend on the RPM that provides the directory for the .xml files.

Version-Release number of selected component (if applicable):
3.8 and newer

Additional info:
The glusterfs.spec.in currently tries to execute "firewall-cli --reload". The correct way is to call the %firewalld_reload macro from /usr/lib/rpm/macros.d/macros.firewalld (provided by firewalld-filesystem).

Comment 1 Worker Ant 2017-01-10 09:52:22 UTC
REVIEW: http://review.gluster.org/16370 (rpm: depend on firewalld-filesystem for directory ownership) posted (#1) for review on release-3.8 by Niels de Vos (ndevos@redhat.com)

Comment 2 Worker Ant 2017-01-12 16:07:44 UTC
COMMIT: http://review.gluster.org/16370 committed in release-3.8 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit e87e2e37499be772a31191dd45bf3a362a93ffde
Author: Niels de Vos <ndevos@redhat.com>
Date:   Tue Jan 10 10:51:00 2017 +0100

    rpm: depend on firewalld-filesystem for directory ownership
    
    Also use the %firewalld_reload macro that is provided by the
    firewalld-filesystem package.
    
    Cherry picked from commit f99750b4477538cd1f97ce6340e1813202f986e2:
    > BUG: 1410853
    > Change-Id: Ibbbc18cc394f8b1e5ba74927effc41c466667479
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-on: http://review.gluster.org/16351
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > Tested-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    
    Change-Id: Ibbbc18cc394f8b1e5ba74927effc41c466667479
    BUG: 1410852
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/16370
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Worker Ant 2017-01-13 13:38:51 UTC
REVIEW: http://review.gluster.org/16410 (rpm: fix glusterfs-server(%postun) scriptlet error) posted (#1) for review on release-3.8 by Niels de Vos (ndevos@redhat.com)

Comment 4 Worker Ant 2017-01-14 11:03:29 UTC
COMMIT: http://review.gluster.org/16410 committed in release-3.8 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit db079ea2be121cfa3616de2b6dae844ab5a979c2
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Jan 13 14:31:27 2017 +0100

    rpm: fix glusterfs-server(%postun) scriptlet error
    
    While introducing the usage of the %firewalld_restart macro, the old
    scriplet was not correctly removed. This causes an error to be displayed
    when the RPM gets updated or uninstalled.
    
    Cherry picked from commit e3d09359b2090c0dc9160b693969f69ecda3477c:
    > Fixes: f99750b4477538cd1f97ce6340e1813202f986e2
    > Change-Id: I69091d8e9e3c412dc3cb52246967eac29d2ebc90
    > BUG: 1410853
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    
    Fixes: e87e2e37499be772a31191dd45bf3a362a93ffde
    Change-Id: I69091d8e9e3c412dc3cb52246967eac29d2ebc90
    BUG: 1410852
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/16410
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 5 Niels de Vos 2017-02-20 12:33:40 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.9, please open a new bug report.

glusterfs-3.8.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2017-February/000066.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.