Bug 1410855 - NFSv4 id mapping issues in multi-domain environments [rhel-6]
Summary: NFSv4 id mapping issues in multi-domain environments [rhel-6]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils-lib
Version: 6.8
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: ChunYu Wang
URL:
Whiteboard:
Depends On: 1378557
Blocks: 1269194
TreeView+ depends on / blocked
 
Reported: 2017-01-06 15:56 UTC by Scott Mayhew
Modified: 2020-12-14 07:59 UTC (History)
18 users (show)

Fixed In Version: nfs-utils-lib-1.1.5-12.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1378557
Environment:
Last Closed: 2017-03-21 12:01:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch that will apply against nfs-utils-lib from rhel6 (13.00 KB, patch)
2017-01-06 16:01 UTC, Scott Mayhew
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1419780 0 urgent CLOSED Cannot create file in it's directory using kerberos authentication with nfs-utils-lib-1.1.5-12.el6 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2017:0805 0 normal SHIPPED_LIVE nfs-utils-lib bug fix update 2017-03-21 12:51:40 UTC

Internal Links: 1419780

Comment 1 Scott Mayhew 2017-01-06 16:01:50 UTC
Created attachment 1238016 [details]
patch that will apply against nfs-utils-lib from rhel6

patch backported from upstream libnfsidmap that will apply cleanly to rhel6's nfs-utils-lib package

Comment 23 ChunYu Wang 2017-01-26 05:40:49 UTC
Currently, we can not reproduce this scene but with results from Scott in comment 16 and comment 21, this patch will be effective in this scene.

I will verify it with "Sanity Only" first and keep an eye on whether it reproduces in other idmap related scenes.

Comment 24 ChunYu Wang 2017-01-26 06:17:13 UTC
Moved to ON_QA again, will provide more regression test results later.

Comment 28 ChunYu Wang 2017-02-17 06:03:14 UTC
Since the regression bug 1419780 has been fixed and all related regression tests return expected results like logs in comment 27. I will verify it again with "Sanity Only" and keep an eye on whether it can reproduce in other idmap related scenes.

Move status to VERIFIED and thanks to all participants.

Comment 30 errata-xmlrpc 2017-03-21 12:01:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0805.html


Note You need to log in before you can comment on or make changes to this bug.