Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1410870 - PING api returns empty foreman_auth stanza
Summary: PING api returns empty foreman_auth stanza
Keywords:
Status: CLOSED DUPLICATE of bug 1325995
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 16:24 UTC by Mike McCune
Modified: 2020-09-10 10:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-11 12:26:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 15582 0 None None None 2017-01-11 12:21:01 UTC

Description Mike McCune 2017-01-06 16:24:05 UTC
We currently return an unused and empty value for foreman_auth:

 curl .. https://localhost/katello/api/ping/  



{
    "status": "ok",
    "services": {
        "foreman_tasks": {
            "status": "ok",
            "duration_ms": "34"
        },
        "foreman_auth": {

        },
...

if this block isn't being used we need to remove it from the return of this API call.

Comment 2 Swapnil Abnave 2017-01-11 12:21:02 UTC
Fixed in Katello 3.2.0

http://projects.theforeman.org/issues/15582

Comment 3 Brad Buckingham 2017-01-11 12:26:40 UTC
Thanks Swapnil!  Closing as a duplicate.

*** This bug has been marked as a duplicate of bug 1325995 ***


Note You need to log in before you can comment on or make changes to this bug.