Bug 1410878 - SELinux is preventing cupsd from 'unlink' accesses on the file printers.conf.O.
Summary: SELinux is preventing cupsd from 'unlink' accesses on the file printers.conf.O.
Keywords:
Status: CLOSED DUPLICATE of bug 1410877
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4ba6ee15e62fe818b72b426562d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 17:03 UTC by Richard Troxel
Modified: 2017-01-06 21:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-06 21:00:13 UTC
Type: ---


Attachments (Terms of Use)

Description Richard Troxel 2017-01-06 17:03:49 UTC
Description of problem:
SELinux is preventing cupsd from 'unlink' accesses on the file printers.conf.O.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that cupsd should be allowed unlink access on the printers.conf.O file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'cupsd' --raw | audit2allow -M my-cupsd
# semodule -X 300 -i my-cupsd.pp

Additional Information:
Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_tmp_t:s0
Target Objects                printers.conf.O [ file ]
Source                        cupsd
Source Path                   cupsd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-225.3.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.8.15-300.fc25.x86_64 #1 SMP Thu
                              Dec 15 23:10:23 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2017-01-04 11:55:52 EST
Last Seen                     2017-01-04 11:55:52 EST
Local ID                      2ab240c3-08c9-40ec-8960-c77e2d720c13

Raw Audit Messages
type=AVC msg=audit(1483548952.181:4626): avc:  denied  { unlink } for  pid=3639 comm="cupsd" name="printers.conf.O" dev="dm-0" ino=661899 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file permissive=1


Hash: cupsd,cupsd_t,user_tmp_t,file,unlink

Version-Release number of selected component:
selinux-policy-3.13.1-225.3.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.8.15-300.fc25.x86_64
type:           libreport

Comment 1 Daniel Walsh 2017-01-06 21:00:13 UTC

*** This bug has been marked as a duplicate of bug 1410877 ***


Note You need to log in before you can comment on or make changes to this bug.