Bug 141090 - [chinputLE]unable to commit characters after switching application
[chinputLE]unable to commit characters after switching application
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: iiimf-le-chinput (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Qingyu Wang
: i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-11-29 02:33 EST by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-12 00:12:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2004-11-29 02:33:38 EST
Description of problem:
After switching between application when preedit buffer is not empty,
LE is unable to commit the characters in the candidate window even
though the information is correct.

Version-Release number of selected component (if applicable):
iiimf-le-chinput-0.3-15

How reproducible:
Always

Steps to Reproduce:
1.Log in as normal user at gdm with zh_CN locale
2.start gnome-terminal
3.in gnome-terminal, run gedit &
4.in gedit, toggle on LE and enter 'hong' without commit
5.alt+tab to switch to gnome-terminal
6.in gnome-terminal, toggle on LE and enter 'mao' without commit
7.alt+tab to switch back to gedit
8.enter '1' to commit the first character in the candidate window
  
Actual results:
1 is displayed

Expected results:
the first character in the candidate window

Additional info:
Comment 2 Lawrence Lim 2005-10-12 00:12:14 EDT
We strive to work with the upstream community of open source projects. This
allows us to reduce the likelihood of regressions between releases as well as to
benefit from features and fixes as development moves forward. Since this change
would require a divergence from the upstream project, please report this issue
to IIIMF developers by filing a bug report in the OpenI18N bugzilla located at
http://openi18n.org/bugzilla/ in the "IIIMF" component.

We urge you to bring the information upstream, so that it can be incorporated in
the next release. Once you've filed your bug report to OpenI18N, if you paste
the new bug URL here, we will continue to track the issue in the centralized
OpenI18N bug tracker, and will review any bug fixes that become available for
consideration in future updates.

Thanks. 

Note You need to log in before you can comment on or make changes to this bug.