Bug 1410900 - Some programs (nm-connection-editor, pavucontrol) crash on Wayland upon dropping any menu/combobox down (via mouse click or spacebar while focused)
Summary: Some programs (nm-connection-editor, pavucontrol) crash on Wayland upon dropp...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: wlc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabio Alessandro Locati
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 19:08 UTC by Jan Pokorný [poki]
Modified: 2017-01-26 13:07 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-23 09:58:46 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github Cloudef wlc issues 210 0 None None None 2017-01-14 13:37:31 UTC
Red Hat Bugzilla 1293993 0 unspecified CLOSED Crash when clicking on a drop-down list (GtkComboBox) in a wayland env 2021-02-22 00:41:40 UTC

Internal Links: 1293993

Description Jan Pokorný [poki] 2017-01-06 19:08:16 UTC
In terminal, following goodbye message is logged at that moment:

> (nm-connection-editor:5214): Gdk-WARNING **:
> Error 71 (Protocol error) dispatching to Wayland display.

$ rpm -q nm-connection-editor xorg-x11-server-Xwayland
> nm-connection-editor-1.4.0-1.fc26.x86_64
> xorg-x11-server-Xwayland-1.19.0-3.fc26.x86_64

Comment 1 Jan Pokorný [poki] 2017-01-06 19:11:02 UTC
Similar to [bug 1397096].

Comment 2 Jan Pokorný [poki] 2017-01-06 22:25:36 UTC
...or [bug 1350060] that even have some clues.

Comment 3 Jan Pokorný [poki] 2017-01-09 10:44:25 UTC
Note that I am able to select the desired option from the drop down
if I carefully avoid displaying the whole menu, but switch the focus
to the selection component (if not already) and use up/down keys for
selection instead.  This uniformly applies to all the occurrences
-- I was able to get pass the initial issue this the said trick, but
later observed the same behavior, e.g., in "add wifi" dialog with
another drop down.  Note that the behavior is furthermore inconsistent
in that now I cannot even open the "add wifi" dialog anymore as
nm-connection-editor crashes even earlier.

I realize I should get some verbose log but currently have no pointers
to this area.

Comment 4 Jan Pokorný [poki] 2017-01-09 11:06:26 UTC
In fact I can observe this crashing/forced close behavior with any drop
down menus at the very moment of "expose options" if the program in
question seems gtk-based (except for firefox that handles drop downs
correctly (perhaps it renders them on its own all the time).
Noting again that I observe this behavior when on Wayland (sway WM).

Hence moving the bug for gtk component as an estimation of the real
root cause component.  Please move further if suitable.

gtk3-3.22.6-1.fc26.x86_64
gtk2-2.24.31-2.fc26.x86_64

Comment 5 Jan Pokorný [poki] 2017-01-09 13:19:05 UTC
In contrast, gimp (2.8.18-3.fc26.x86_64) is not affected AFAICT.

Comment 6 Jan Pokorný [poki] 2017-01-09 16:48:10 UTC
Confirmed this bug may indeed have something to do with gtk3 thanks
to gtk3-demo from gtk3-devel -- all the combo boxes from the palette
expose this issue.

Note that gtk2-demo works just fine on this Wayland setup.

Comment 7 Jan Pokorný [poki] 2017-01-09 17:01:18 UTC
Also affected (from gtk3-demo):
- Pickers: Folder + Mail
- Menus: any click on the main menu
- Size Groups: another reproducer for the drop downs
- Printing - Page Setup: Format for + Paper size (ditto dropdowns)

Comment 8 Jan Pokorný [poki] 2017-01-10 11:15:56 UTC
Searching through other bugs, this seems to be a regression,
reintroduction of [bug 1293993].

Comment 9 Jan Pokorný [poki] 2017-01-13 09:33:18 UTC
Note that running affected applications with GDK_BACKEND=x11 in the
environment helps (modulo one new segfault in one particular case:
[bug 1412958].

The results are still suboptimal, though, exposed comboboxes are
immediately overlaid by the originating dialog/window once the cursor
move a single pixel.

Comment 10 Jan Pokorný [poki] 2017-01-14 13:37:31 UTC
Found that wlc (compositor library beneath sway on which I reproduce
the issues) is likely the culprit:
https://github.com/Cloudef/wlc/issues/210

Switching the component respectively.

Comment 11 Fabio Alessandro Locati 2017-01-15 08:56:32 UTC
Thanks for reporting, but it seems like it's an upstream problem.
I'm going to link this bug on the upstream discussion, and we are going to wait for upstream to fix it.
Also, in https://github.com/SirCmpwn/sway/issues/986 you can notice that someone put a 20$ bounty on that bug, so hopefully this will be fixed soon.

Comment 12 Fabio Alessandro Locati 2017-01-23 09:58:46 UTC
I close this bug, since the upstream bug has been fixed by https://github.com/Cloudef/wlc/commit/208b18c81886282f4b41d6c65fdf8e5a203dda91

Comment 13 Jan Pokorný [poki] 2017-01-26 13:06:28 UTC
Confirming forced exits are gone in those cases with
wlc-0.0.7-2.git12ee978.fc26.x86_64

(modulo [bug 1412958], which is not bound to wlc, though)

Unfortunately, the current results are still suboptimal, the dropdown
appears in an unexpected location (top right corner, no relative
positioning in relation with original dialog/window).  That may have
something to do with gtk3 internals.

Comment 14 Jan Pokorný [poki] 2017-01-26 13:07:45 UTC
Sorry, in fact it is top left corner.


Note You need to log in before you can comment on or make changes to this bug.