Bug 1410921 - [rbd-mirror] sporadic image replayer shut down failure
Summary: [rbd-mirror] sporadic image replayer shut down failure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.2
Assignee: Jason Dillaman
QA Contact: Rachana Patel
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 20:57 UTC by Jason Dillaman
Modified: 2017-07-30 15:27 UTC (History)
2 users (show)

Fixed In Version: RHEL: ceph-10.2.5-7.el7cp Ubuntu: ceph_10.2.5-3redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-14 15:47:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 18441 0 None None None 2017-01-06 20:57:24 UTC
Red Hat Product Errata RHBA-2017:0514 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.2 bug fix and enhancement update 2017-03-21 07:24:26 UTC

Description Jason Dillaman 2017-01-06 20:57:25 UTC
Description of problem:
Possible live-lock of rbd-mirror daemon's image replayer state machine during stop

Version-Release number of selected component (if applicable):
10.x

How reproducible:
rare -- integration test rbd_mirror_stress occasionally hits the issue

Steps to Reproduce:
1. mirror an image
2. stop rbd-mirror on the non-primary
3. inject lots of IO events into the primary image
4. restart rbd-mirror on the non-primary site
5. while rbd-mirror is replaying the IO events, attempt a graceful shut down

Actual results:
There is a possibility that the image replayer state machine will get live-locked in the STOPPING state.

Expected results:
The image replayer should cleanly shut down.

Additional info:

Comment 5 Rachana Patel 2017-02-23 03:13:16 UTC
verified with version - 10.2.5-29.el7cp.x86_64

followed steps mentioned in description and works for me hence moving to verified

Comment 7 errata-xmlrpc 2017-03-14 15:47:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0514.html


Note You need to log in before you can comment on or make changes to this bug.