Bug 1410924 - [GSS](6.4.z) Incorrect JBOSS_HOME warning in vault.sh
Summary: [GSS](6.4.z) Incorrect JBOSS_HOME warning in vault.sh
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Scripts and Commands
Version: 6.4.12
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: CR1
: EAP 6.4.20
Assignee: jboss-set
QA Contact: Peter Mackay
URL:
Whiteboard:
Depends On:
Blocks: eap6420-payload
TreeView+ depends on / blocked
 
Reported: 2017-01-06 21:01 UTC by dereed
Modified: 2020-02-14 18:25 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-19 12:42:45 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker JBEAP-8135 0 Minor Verified [GSS](7.1.0) Incorrect JBOSS_HOME warning in vault.sh 2018-06-21 08:55:14 UTC
Red Hat Issue Tracker JBEAP-8154 0 Minor Verified [GSS](7.0.z) Incorrect JBOSS_HOME warning in vault.sh 2018-06-21 08:55:14 UTC
Red Hat Issue Tracker WFCORE-2160 0 Minor Resolved Incorrect JBOSS_HOME warning in vault.sh 2018-06-21 08:55:14 UTC

Description dereed 2017-01-06 21:01:41 UTC
vault.sh has an incorrect check to make sure JBOSS_HOME is set correctly.

SANITIZED_JBOSS_HOME=`cd "$JBOSS_HOME/.."; pwd`
if [ "$RESOLVED_JBOSS" != "$SANITIZED_JBOSS_HOME" ]; then

The check will always fail because of the incorrect "/..", which should be removed.

The incorrect value is only used for printing the "WARNING JBOSS_HOME may be pointing to a different installation - unpredictable results may occur." log, and appears to have been around since at least EAP 6.0.

Comment 1 Romain Pelisse 2017-01-09 09:28:38 UTC
I will be working on a fix for upstream issue (WFCORE-2160/JBEAP-8135) - which most likely will be easy to backport into 6.4.x.

Comment 2 Romain Pelisse 2017-01-16 14:42:47 UTC
Pull Request: https://github.com/jbossas/jboss-eap/pull/2918

Comment 3 Ivo Hradek 2017-06-07 07:36:48 UTC
Verification failed for EAP-6.4.16-CP.CR1;

Similarly as in JBEAP-8154 / JBEAP-8135 there is undefined variable `$RESOLVED_JBOSS` (line 51), so the warning is still printed anyway.
Changing this to `$RESOLVED_JBOSS_HOME` (defined on line 45) should worked as expected.

Comment 6 Slavcho Stavrev 2017-06-14 12:46:02 UTC
PR: https://github.com/jbossas/jboss-eap/pull/3011

Comment 8 Jiří Bílek 2018-04-27 09:12:40 UTC
Regression tests passed
Verified with EAP 6.4.20.CP.CR1


Note You need to log in before you can comment on or make changes to this bug.