Bug 141093 - segfault in mkisofs
segfault in mkisofs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cdrtools (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-29 02:44 EST by John Summerfield
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 12:15:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Summerfield 2004-11-29 02:44:53 EST
Description of problem:
segfault and NULL pointer messages from mkisofs

Version-Release number of selected component (if applicable):
2.01.0.a38

How reproducible:
allways

Steps to Reproduce:
1.rm -rf /tmp/Isolinux
2.cp -vfpr /var/local/mirrors/linux/RHEL/3.95/i386/os/isolinux /tmp/
3.mv -f /tmp/isolinux /tmp/Isolinux
4.mkisofs -o EL395-dvd.iso -A 'EL/3.95 i386' -V 'EL/3.95 i386' -J -R
-T -q -x ./lost+found -no-emul-boot -boot-load-size 4 -boot-info-table
-x isolinux /tmp/Isolinux /var/local/mirrors/linux/RHEL/3.95/i386/os

  
Actual results:
/home/summer/bin/RHEL-DVD: line 20: 18249 Segmentation fault     
mkisofs -o EL395-dvd.iso -A "EL/3.95 i386" -V "EL/3.95 i386" -J -R -T
-q -x ./lost+found -no-emul-boot -boot-load-size 4 -boot-info-table -x
isolinux /tmp/Isolinux /var/local/mirrors/linux/RHEL/3.95/i386/os


Expected results:
And iso at EL395-dvd.iso

Additional info:
Probably this is related:
+ mv -f /tmp/isolinux /tmp/Isolinux
+ mkisofs -o EL395-dvd.iso -b Isolinux/isolinux.bin -A 'EL/3.95 i386'
-V 'EL/3.95 i386' -J -R -T -q -x ./lost+found -c Isolinux/boot.cat
-no-emul-boot -boot-load-size 4 -boot-info-table -x isolinux
/tmp/Isolinux /var/local/mirrors/linux/RHEL/3.95/i386/os
Unknown file type (unallocated) /tmp/Isolinux/.. - ignoring and
continuing.
mkisofs: Uh oh, I cant find the boot catalog directory 'Isolinux'!

The primary source is an unpacked Nahant AS CD set.
Comment 1 Jay Turner 2004-11-29 04:04:39 EST
Will have to poke into why mkisofs is falling over, but your second example
above isn't correct mkisofs syntax in the first place, hence the error message.
 Both the boot catalog and the boot image need to be specified relative to the
source paths listed on the command line, so the command above is telling mkisofs
to look for "Isolinux/isolinux.bin" and "Isolinux/boot.cat" in the
"/tmp/Isolinux" and "/var/local/mirrors/linux/RHEL/3.95/i386/os" directories,
where, of course, it doesn't exist.  Running the following command does indeed
work, however:

mkisofs -o EL395-dvd.iso -b isolinux.bin -A 'EL/3.95 i386' -V 'EL/3.95 i386' -J
-R -T -q -x ./lost+found -c boot.cat -no-emul-boot -boot-load-size 4
-boot-info-table -x ./isolinux /tmp/Isolinux
/var/local/mirrors/linux/RHEL/3.95/i386/os
Comment 2 Jay Turner 2004-11-29 04:05:11 EST
Fix summary typo.
Comment 3 John Summerfield 2004-11-29 09:36:47 EST
I since have create a working commandline. I'venot yet established
that it does what I want though.

I suggest that mkisofs should be properly validating parameter info
including checking for consistency and that it's not doing this. This
would likely give rise to erroneous messages and segfaults, and quite
possibly in some contexts, security exposures.

I know my commandline was wrong, but that doesn't make messages about
null pointers (whoops I didn't actually show that one) permissable.

Luckily I still have one:
+ mkisofs -o EL394-dvd.iso -b isolinux/isolinux.bin -A 'EL/3.94 i386'
-V 'EL/3.9
4 i386' -J -R -T -q -x ./lost+found -c isolinux/boot.cat -no-emul-boot
-boot-loa
d-size 4 -boot-info-table /tmp/isolinux
/var/local/mirrors/linux/RHEL/3.95/i386/
os
Unknown file type (unallocated) /tmp/isolinux/.. - ignoring and
continuing.
mkisofs: Error: (NULL POINTER) and
/var/local/mirrors/linux/RHEL/3.95/i386/os/is
olinux/boot.cat have the same Joliet name

Note You need to log in before you can comment on or make changes to this bug.