Bug 1410943 - Can't fine tune the key press speed / delay of a Fedora 25 guest OS
Summary: Can't fine tune the key press speed / delay of a Fedora 25 guest OS
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 22:52 UTC by danielemi
Modified: 2020-01-26 18:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-26 18:28:08 UTC


Attachments (Terms of Use)

Description danielemi 2017-01-06 22:52:39 UTC
Description of problem:
In an environment with Fedora 25 as host OS and guest OS, I'm unable to fine tune the key press speed and delay of the keyboard. This is quite tedious problem especially doing development inside the guest.  

Version-Release number of selected component (if applicable):
1.4.0-5.fc25

How reproducible:
always

Comment 1 Cole Robinson 2017-03-29 18:21:29 UTC
spice display has a keypress-delay setting, which can be tweaked with an environment variable SPICE_KEYPRESS_DELAY. Default is 100ms. So you can try that and see if it fixes things for you. Could be that there are other problems though, google 'spice keypress delay' there's a few interesting hits

vnc display doesn't have any keypress delay/timing options though

TBH I don't see this as something we would add to virt-manager UI, which doesn't aim to exhaustively cover all display options, because there's a ton. That's something I think virt-viewer should do which aims to be the universal viewer

Comment 2 Cole Robinson 2020-01-26 18:28:08 UTC
Per the recent design document, I think this request falls under 'advanced VNC/SPICE viewer config' and is better left to dedicated tools for that, like virt-viewer. So this will not be implemented in virt-manager, sorry.
Closing as WONTFIX


Note You need to log in before you can comment on or make changes to this bug.