Bug 1410949 - upgrade tool looks for .treeinfo but not treeinfo
Summary: upgrade tool looks for .treeinfo but not treeinfo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-upgrade-tool
Version: 6.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Bocek
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1429926
TreeView+ depends on / blocked
 
Reported: 2017-01-06 23:23 UTC by Chris Duryee
Modified: 2020-09-10 10:06 UTC (History)
9 users (show)

Fixed In Version: redhat-upgrade-tool-0.7.49-1.el6
Doc Type: Release Note
Doc Text:
Red Hat Upgrade Tool searches for both `treeinfo` and `.treeinfo` files With this update, Red Hat Upgrade Tool searches for both the `treeinfo` and `.treeinfo` files in a repository provided through the command line, because some CDN services do not support files that start with a dot.
Clone Of:
Environment:
Last Closed: 2017-08-02 00:08:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2401 0 normal SHIPPED_LIVE redhat-upgrade-tool bug fix and enhancement update 2017-08-01 22:03:50 UTC

Description Chris Duryee 2017-01-06 23:23:41 UTC
Description of problem:

The redhat upgrade tool looks for ".treeinfo" files, but does not look for "treeinfo". This causes issues with repos that are synced down from the CDN. Ideally, the upgrade tool would check for treeinfo if .treeinfo didn't exist, then error if both didnt exist.

The BZ mentioned in "additional info" has more info about why the file is just "treeinfo" on the CDN.

Version-Release number of selected component (if applicable): 0.7.48

How reproducible: every time

Steps to Reproduce:
1. sync RHEL 7 kickstart from CDN to Satellite 6.2 installation
2. download debug cert to client
3. create /etc/yum.repos.d/upgrade.repo file that uses the satellite debug cert to obtain RHEL 7 for the upgrade
4. attempt to upgrade using that repo

Actual results: upgrade tool aborts when it cannot find .treeinfo


Expected results: tool looks for .treeinfo and treeinfo, similar to anaconda.


Additional info:

https://bugzilla.redhat.com/show_bug.cgi?id=635065

Comment 2 Chris Duryee 2017-01-09 15:28:57 UTC
minor change to comment #0: kickstart repos are available on the satellite via http, so the debug cert is not needed. If you need a test satellite to repro this, just let me know.

Comment 3 Michal Bocek 2017-05-17 15:46:22 UTC
Fix prepared in upstream:
https://github.com/upgrades-migrations/redhat-upgrade-tool/commit/865e87a412fe54cda522c5e10dfb85e3c4dbd465
Chris, please send me link to a repo that has treeinfo instead of .treeinfo, so I can test it. Thanks.

Comment 4 Jason Dickerson 2017-05-17 16:16:26 UTC
The kickstart tree (Installation media) for RHEL 7.x has this issue.  You can test with RHEL 7.3 if you like.

Comment 5 Michal Bocek 2017-05-18 12:09:40 UTC
I prepared a repo on an http storage, basically a copy of the official 7.3 repo. I renamed .treeinfo to treeinfo and the fix works - treeinfo gets downloaded.

Comment 10 errata-xmlrpc 2017-08-02 00:08:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2401


Note You need to log in before you can comment on or make changes to this bug.