Bug 141095 - disk ordering fails raidstart
disk ordering fails raidstart
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: raidtools (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-29 02:55 EST by Wendy Cheng
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 11:20:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wendy Cheng 2004-11-29 02:55:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:

Reported via IT#53591
Customer: IBM-IGS/HSBC Bank Brazil
RHEL 3 bugzilla # 141091

If you have a mirrored raid device ( raid level 1 ), and one disk
encounters fatal errors, the raid device continues to operate on the
other disk, as expected.

However if the device is stopped and restarted then the raidstart will
fail if the failing hardware is the first listed in the raidtab ( e.g.
raid-disk 0 ).

If the first raid-disk is operational, then the md device will start
irrespective of the status of the second raid-disk.

The customer encountered the problem on an EMC array; it is also
recreated using my test machine on both AS2.1 and RHEL 3. 

The problem seems to be with raidstart, which only attempts the first
listed disk irrespective of the raid level. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. (see bugzilla 141091 for details)
2.
3.
    

Additional info:

IT ticket is opened against AS2.1 but I did all the
testing/verification on RHEL 3. Customer expects the problem being
fixed both on AS2.1 and RHEL 3.
Comment 1 Wendy Cheng 2004-12-10 11:12:50 EST
Patch included into bugzilla 141091.
Comment 7 John Flanagan 2005-04-28 11:20:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-179.html

Note You need to log in before you can comment on or make changes to this bug.