Bug 1410952 - rust FTBFS with LLVM 3.8 on s390x
Summary: rust FTBFS with LLVM 3.8 on s390x
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rust
Version: 25
Hardware: s390x
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Rust SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1410950 1412204
Blocks: ZedoraTracker
TreeView+ depends on / blocked
 
Reported: 2017-01-06 23:37 UTC by Josh Stone
Modified: 2017-06-20 13:48 UTC (History)
11 users (show)

Fixed In Version: rust-1.18.0-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1410950
Environment:
Last Closed: 2017-06-20 13:48:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Josh Stone 2017-01-06 23:37:23 UTC
+++ This bug was initially created as a clone of Bug #1410950 +++

Description of problem:
Attempts to bootstrap Rust on s390x failed with an LLVM ERROR on f24 and f25.  The same srpm on f26 (with LLVM 3.9) is fine.

f24: https://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2439756
f25: https://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2439754

Version-Release number of selected component (if applicable):
llvm-3.8.0-1.fc25/24
building rust-1.14.0-1.fc25/24

How reproducible:
100%

Steps to Reproduce:
1. rpmbuild --rebuild rust-1.14.0-1.fc25.src.rpm
(or try again on s390.koji)

Actual results:
LLVM ERROR: Cannot select: 0x3ff793b6d90: ch = AtomicFence 0x3ff70818a70, Constant:i64<4>, Constant:i64<1>
  0x3ff728d89c0: i64 = Constant<4>
  0x3ff793b7120: i64 = Constant<1>
In function: _ZN33_$LT$alloc..arc..Arc$LT$T$GT$$GT$9drop_slow17h19a3f415d8721b31E

Expected results:
no compiler errors :)

Additional info:
A similar problem was reported upstream for compiling v8 with Clang 3.8, then closed when it was found to work with 3.9.  That's probably a simpler reproducer.
https://llvm.org/bugs/show_bug.cgi?id=28735

Also, the rawhide builds of Rust with LLVM 3.9 were fine:
https://s390.koji.fedoraproject.org/koji/buildinfo?buildID=449416
https://s390.koji.fedoraproject.org/koji/buildinfo?buildID=449417

Comment 1 Fedora Admin XMLRPC Client 2017-01-24 18:42:00 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Dan Horák 2017-05-10 13:07:27 UTC
Because there is now llvm 3.9 in F-25 for some time it should be possible to get Rust built there too. I'll try some tricks :-)

Comment 3 Dan Horák 2017-06-20 13:48:52 UTC
I've rebuilt the "old" portion of the rust stack with llvm 3.9 instead of llvm 3.8 and all went well till the latest rust and cargo.


Note You need to log in before you can comment on or make changes to this bug.