Bug 1410955 - After upgrading from 3.5 to 3.6, engine was left with two admin users
Summary: After upgrading from 3.5 to 3.6, engine was left with two admin users
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.9
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Martin Perina
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-07 00:01 UTC by emahoney
Modified: 2020-03-11 15:43 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 12:44:15 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)

Description emahoney 2017-01-07 00:01:38 UTC
Description of problem:
After upgrading from 3.5 to 3.6, there were two admin users internal and internal-authz. This made logins fail due to the errors below:

~~~
2017-01-03 21:05:44,570 ERROR [org.ovirt.engine.core.aaa.filters.BasicAuthenticationFilter] (ajp-/127.0.0.1:8702-7) [] User admin authentication failed. profile is internal. Invocation Result code is 0. Authn result code is ACCOUNT_RESTRICTION
2017-01-03 21:05:45,243 INFO  [org.ovirt.engine.extension.aaa.jdbc.core.Authentication] (ajp-/127.0.0.1:8702-14) [] locking user: admin due to interval failures
~~~

Version-Release number of selected component (if applicable):
After the upgrade, the env is now at 3.6.8. Cannot confirm at this point where the env started on 3.5.x. 

How reproducible:
Have not been able to reproduce this

Comment 1 Oved Ourfali 2017-01-07 14:49:13 UTC
Please provide complete engine and setup logs.


Note You need to log in before you can comment on or make changes to this bug.